Upgrade from Admin: Operation not permitted

docker

(Quân Nguyễn) #1

I tried to upgrade Discourse from Admin UI, but failed due to “Operation not permitted” error

$ cd /var/www/discourse && git fetch && git reset --hard HEAD@{upstream}
warning: unable to unlink app/assets/javascripts/admin/models/report.js: Operation not permitted
warning: unable to unlink app/assets/javascripts/discourse/templates/search/category_result.hbs: Operation not permitted
warning: unable to unlink app/assets/javascripts/discourse/templates/search/post_result.hbs: Operation not permitted

Tried looking for similar topic in this forum, but not found. So I have to create this topic. Here is the Linux account detail:

  • The docker software is installed with sudo apt-get, by kaka_root user. This user is normal user, but is “sudoer”.
  • The git repo discourse_docker is cloned by kaka_dev user. This user is not “sudoer”. This user can run ./launcher ssh app successfully, and become root inside container after that. This user can also run ./launcher rebuild app successfully.
  • Inside container, the folder /var/www/discourse/ is under discourse user.

Platform detail:
Linux hostname 3.5.0-52-generic #79~precise1-Ubuntu SMP Fri Jul 4 21:03:49 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

I can upgrade Discourse successfully with ./launcher command. But my team want to be able to do in Admin UI.

How can I solve this?
Thanks and regards.


(Sam Saffron) #2

Some older versions require a rebuild, once that is done it should be fine going forward.


(Quân Nguyễn) #3

I rebuilt by command line. After some days, Discourse had new update, tried from Admin but failed, had to rebuild by command line. After that, Discourse had new update again, tried to upgrade from Admin again and still not work.

— Update —
Just noticed that our server is using kernel v3.5, far older than Docker requirement, v3.10. This may be the cause of the problem.


(Jeff Atwood) #4