Upgrade V2.1 Beta 2 to Beta 4 Require ./launcher rebuild app Twice


(Ridha) #1

Hi, I just upgrade my Discourse from v2.1.0beta2 to v2.1.0beta4 yesterday.

Then I got these message:

upgrade%20image


You are running an old version of the Discourse image.

Upgrades via the web UI are disabled until you run the latest image.

To do so log in to your server using SSH and run:

cd /var/discourse
git pull
./launcher rebuild app

More info on our support site.


I follow the guideline by running that ssh command, then I can not access my Discourse site. :cold_face:
Fortunately, I make a snapshot in Digital Ocean right before that three command.
Restore my droplet and its live again. :grinning:

I run the tree commands above again and read this message after finishing the ./launcher rebuild app process.


Sync data directory to disk ok
Creating script to analyze new cluster ok
Creating script to delete old cluster ok
Checking for hash indexes ok

Upgrade Complete

Optimizer statistics are not transferred by pg_upgrade so, once you start the new server, consider running:

./analyze_new_cluster.sh

Running this script will delete the old cluster’s data files:
./delete_old_cluster.sh

UPGRADE OF POSTGRES COMPLETE

Old 9.5 database is stored at /shared/postgres_data_old

To complete the upgrade, rebuild again using:

./launcher rebuild app


Then, I tried to running ./launcher rebuild app again and its works. :grinning: :partying_face:

My questions:

  1. Am I on the right track?
  2. Should I delete the old cluster’s data files by running ./delete_old_cluster.sh command?

Is there any additional tips instead of upgrading my discourse frequently?

Thank you…


Error when updating Discourse to 2.2.0.beta3
(Jay Pfaffman) #2

You’re fine.

You can run

./launcher cleanup 

To remove the extra database backup


(Ridha) #3

Thank you for the quick reply. :pray:

So, I enter my SSH and running?

cd /var/discourse
git pull
./launcher cleanup

(Stephen) #4

You shouldn’t need to git pull just to run cleanup, no. Just the other two statements.


(system) #5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.