Upgrade link no longer works

Most everyday I run the upgrade in the admin console, it came up today and said all was fine, I went in to check for changes and this message came up

You are running an old version of the Discourse image.

Upgrades via the web UI are disabled until you run the latest image.

To do so log in to your server using SSH and run:

cd /var/discourse git pull ./launcher rebuild app

More info on our support site

Now the upgrade stage does not work, it just display this, I did perform the steps

but it is now broke

I’m at ver 2.8.0 beta 8
Ubuntu server 20.04

Could you share the error during the ./launcher rebuild app command, it would help us find a solution.

It can be a lot of things, it can help points us to a plugin if this is the reason.

1 Like

So you Did you log in to the server and run the rebuild command as instructed?

Broke how?

You might restart the old container with

  ./launcher start app

I had the same issue yesterday.

There is an new docker version. if you upgrade it via the Admin Interface, it tells you that you need to upgrade it via the cmd line.

Just log into your site via cmd line and to a ./launcher rebuild app and it will solve your issue.

1 Like

Is there anything else that would be useful to run at the same time? (for those who don’t use the console frequently) I went with these:

Apt-get update
Apt-get upgrade

cd /var/discourse 
./launcher rebuild app

./launcher cleanup
(Edit: Maybe wait a few days before running, in case you need to restore a previous version)

1 Like

You’re pretty much fine with your choices !

Since I manage a few vps, I run these in order:

apt-get -y update && apt-get -y upgrade
apt-get -y autoremove && apt-get -y autoclean

A reboot as you stated finalize everything. This checkup every few weeks is good enough.

I don’t recommand using the ./launcher cleanup app right after a rebuild tho, because if there’s an issue, it can be helpful to go back quickly to the previous rebuild using ./launcher restart app. A few days later, it’s fine.


I ran into this problem yesterday upgrading from beta7 to beta8; got my dev to run the ./launcher rebuild command and it seems to have resolved. Interested to see the solution/possible cause.

For me it was ‘update docker manager’ first, then ‘update all’ - which did 4 plugins and discourse itself. When it came back up, it showed that discourse and one of the plugins still had an update to run. Clicking update all again just brought up the terminal, and black for over an hour. Refreshing the page brought on the ‘old version of discourse image’.

A few times a year the base image needs to be updated because some underlying library needs am upgrade.

You can watch updates to the discourse_docker github repo, or just do what you’ve been doing and ask your dev to do the update when it’s required.

1 Like