Uploading Images stalls and does not translate to img src tag

s3

(Senthil Kumaran) #1

I am running 1.5.0.beta1 on Digital Ocean Instance.

Setting up file and image uploads to S3 - Is this howto still the accurate and up to date information? I followed it to the dot and still I am unable to set up image upload to s3 in my digital ocean instance of discourse.

I see that my images are getting uploaded to my bucket but in the older original/1X

us-west-2&bucket=thinnal&prefix=original/1X/

The log message

Processing by UploadsController#create as JSON
  Parameters: {"type"=>"composer", "files"=>[#<ActionDispatch::Http::UploadedFile:0x007f9f083c4cc8 @tempfile=#<Tempfile:/tmp/RackMultipart20151002-29190-17rmzjw.jpg>, @original_filename="21210543263_f961218003_z.jpg", @content_type="image/jpeg", @headers="Content-Disposition: form-data; name=\"files[]\"; filename=\"21210543263_f961218003_z.jpg\"\r\nContent-Type: image/jpeg\r\n">], "client_id"=>"xxxxx", "authenticity_token"=>"XXXXAllaJDcrc9J9drnj4CA=="}
Completed 200 OK in 5ms (Views: 0.3ms | ActiveRecord: 0.6ms)

But the operation is struck for me.

https://dl.dropbox.com/s/wvwdpeq3fqs41xs/Screenshot%202015-10-01%2020.03.04.png


(Senthil Kumaran) #2

It is not just s3, even if I disable s3, my image uploads are getting struct in that page.
After 200, it is not translating to img src file.


(Senthil Kumaran) #3

The user guide says

File Uploads

Basic image uploads work fine out of the box stored locally, provided you have adequate disk space.

I have adequate disk space, but the image upload has not been working out of box for me. Any troubleshooting suggestions?

This is infact, my second discussion on the same topic (Discourse Meta) and unfortunately, I haven’t gotten to my goal yet, which it to upload images.


(Mittineague) #4

I don’t have a clue if it makes any difference or even if it is proper, but might the extension being “jpg” and the type being “jpeg” be the problem?

Have you tried using different images?


(Senthil Kumaran) #5

Thanks for the response. It was the file extension. I tried with .png and it still stalled at the same place. I opened Chrome Developer Tools to find what’s happening and it looks like I have some setting where I have to end my hostname with /.


(Sam Saffron) #6

looks like a missing / next to your hosname somewhere… you on latest?


(Senthil Kumaran) #7

Yup, I am trying to hunt down where exactly it is missing ‘/’. I am on 1.5.0.beta1, which is the latest. thanks.


(Senthil Kumaran) #8

Solve it. It was improper customization. In body tag in customizations, I had a wrong tag. Surprised at the effect this caused. Thank you for the support. Let’s close this thread.


(Jeff Atwood) #9