Missing "enable s3 uploads" setting

Hello,

I am using 2.4.0.beta6 (0de7e4339c) and I need to configure S3 upload ( Step 2: Configuring Discourse, Setting up backup and image uploads to DigitalOcean Spaces ), but I do not have “enable s3 uploads” setting. Do you know how preconditions should I do? Or maybe this setting changed name?

When I am filtering “s3”, I have only five options in Settings -> Files (see screen belove).

Could you help me? Because I cannot upload pictures, when I am trying to upload picture:
image

expected :endpoint to be a HTTP or HTTPS endpoint
:frowning:

Does your app.yml file contain environment relating to s3?

1 Like