URL of the external system avatars service setting changes breaks avatars


In the admin settings, the external system avatars url setting, the URL format used is not being applied to all images. Checking the ‘change history’ shows that the default values is used and no change had been made, but if we try to change it, the change will apply on some avatars and many more will break. They’d not appear properly i.e. this setting is not applying on all avatars.

Is there a reason behind this or does this require more debugging because it sounds like a bug?

Thank you!

1 Like

Those avatars are being cached, so you might want to wait for a while before drawing any conclusions (maybe try on a staging copy of your server first).

What are you changing it to? Are you sure that is working correctly?


The reason I’m able to make these conclusions is because I checked the URL. There are avatars which don’t follow the ‘external system avatars url’ setting and there are those avatars that do (and I know that because I checked the links of the avatars that broke and the avatars that didn’t).

1 Like

I’m afraid that you’ll need to be (much) more specific if you want any help.


I’m going to take a stab in the dark here for some clarity.

You have external system avatars enabled enabled, and changed the default value of the external system avatars url setting, correct?

After making the change to the setting only the avatars that were uploaded by users and gravatars are working, correct? If so, what is the exact value you entered for the external url setting?

1 Like