Usernames getting modified – numeral "1" being added


(Travis Northcutt) #1

I run a Discourse instance and WordPress site, using the Discourse SSO plugin (which is awesome).

Recently, two (out of 50+) had 1 appended to their usernames in Discourse. Their usernames on the WordPress site remains unchanged.

I tried to manually edit their usernames back in Discourse, but encountered the error message Username must be unique. However, the username (without the 1 appended) is unique.

Is this a known issue? Is there a workaround for this problem?

Happy to provide whatever other info would be useful for debugging.


(David Taylor) #2

Do you have any groups with names equal to the usernames? Group names and usernames share the same namespace


(Travis Northcutt) #3

Ah, yes!

So will Discourse let you create a group with the name of an existing user, and append 1 to the username, rather than saying “Sorry, you can’t use that group name” when attempting to create the group?


(David Taylor) #4

No, you will get “Group name is not available”.

We had a bug with the validation a few months ago, which might be why you ended up with this situation. The bug is now fixed, so it shouldn’t happen in the future.


(Travis Northcutt) #5

Cool, thank you @david


(David Taylor) #6

This topic was automatically closed after 20 hours. New replies are no longer allowed.