Usernames suddenly have 1 appended to end


(James North) #1

Hi folks,

I tried searching for this one … but can’t find anything explaining it.

I’ve just done an update to one of my Discourse forums just now and almost everyone’s username now has a 1 appended to it.

I can’t unequivocally say that it didn’t happen prior to the update (like maybe it was the previous one) but this is not great.

When I try to manually rename the username as admin, it says the username is in use (but it’s not!).

Any tips/advice?

I am on latest with a pretty standard Ubuntu install.


(James North) #2

Good lord - I’ve solved it.

Evidently groups can no longer have the same name as users.

So the group name and username now count towards ‘uniqueness’.

Disappointing to have to go through and fix it all (every user has their own group for this business forum), but hopefully this helps someone else with the same issue.


(Sam Saffron) #3

The alternative is far worse, if we did not protect it so there is a single namespace @mentioning groups would not work properly on lots of levels.


(James North) #4

I can’t even imagine why you’d want to do that, but there is clearly a demand for it!


(system) #5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.