Version of highlight.js is outdated


(Valentin Churavy) #1

As far as I know discourse is using highlight.js for syntax highlighting.
Would it be possible to update discourse to the newest version of highlight.js ?


(Alex Arslan) #2

In particular, the most recent version of highlight.js (as of this writing, 9.12.0) contains updates to the Julia language definition. More recent Julia versions brought significant changes to some aspects of the syntax, and those are not properly captured in the old Julia definitions in highlight.js, so posts in the Julia Discourse forum that use modern syntax look kind of funky.


(Jeff Atwood) #3

Sure @sam is working on related stuff and can look into this soon.


(Régis Hanol) #4

I just updated highlight.js to 9.12.0 thanks to the highlightjs:update rake task :thumbsup:


(Jeff Atwood) #5