Visiting /admin/upgrade may lead to a server error

If you’re currently running a standard installation of Discourse earlier than v3.1.0.beta7 (or stable earlier than v3.0.6), there is a chance you will be met with this error when attempting to upgrade via the admin UI:

Server Error
while trying to load /admin/docker/repos
Error code: 500 error

To resolve the issue, you will need to run a command-line rebuild:

cd /var/discourse
./launcher rebuild app

Once you’ve run a CLI upgrade, future upgrades via the UI will work fine.

If this has affected you, please let us know in this poll:

  • This affected my self-hosted forum
0 voters


This error is happening because of some recent changes to our .discourse-compatibility file format. Older versions of Discourse are unable to parse compatibility information for plugins which have started using the new format, and therefore throw this error.

Very few plugins have started using the new syntax, so we don’t expect this to be a particularly widespread issue. We’ll keep an eye on things, and update here if there are any developments.


Hi David,

coming from Internal Server Error on Upgrade page, we wanted to report that our Discourse instance on trips with the same error.

ArgumentError (Malformed version number string < 3.2.0.beta2) lib/version.rb:44:in `block in find_compatible_resource' lib/version.rb:44:in `each' lib/version.rb:44:in `sort_by' lib/version.rb:44:in ` 

We are running 3.1.0.beta1 (92bb728fe5). is a pretty much vanilla installation, and I just tried to install Custom Header Links and Custom Header Links (icons), in order to customize it a bit. Given that 3.1.0.beta1 isn’t also that old, the issue may be more widespread than anticipated?

It is not a problem at all, we will happily run the CLI upgrade and everything will be good afterwards. We just wanted to make you aware of the fact that not only UI-based Discourse upgrades are impacted, but also the installation of arbitrary plugins, apparently.

1 Like