WARNING: Port 443 of computer does not appear to be accessible using hostname: forum.rlv.link

When I try to install Discourse, I get this error every time:

DNS:

I’m using CloudFlare

I have searched many posts here but have not found a solution (that works for me).
I installed Apache2 because it runs the normal website.

If i ping the domain:
https://i.imgur.com/nFdEkUc.png

The issue is probably happening because of cloudflare proxy. You’ll have to disable cloudflare optimization by clicking orange cloud and making it grey on the DNS page in cloudflare for the given (sub)domain. If you’d rather have cloudflare, You’ll need to edit the configuration file manually to disable the discourse built in ssl.

2 Likes

Thanks, i try it. Should I expect certain “waiting periods”?

It should be immediate in most cases byt you can wait ~5 minutes after changes to be extra safe. You can ping your domain and as soon as it starts replying from your VPS IP address instead of cloudflare IP, you should be good to go.

What do I have to enter there or what does it mean?
image

Discourse need credentials for a SMTP (email) server in order to be able to send emails. More information about this is available here:

discourse/INSTALL-email.md at master · discourse/discourse · GitHub

1 Like

Not working. I get this error

what is the output of
netstat -alpn | grep 80

image

Then you can’t use discourse-setup. Have a look at How to set up Discourse on a server with existing Apache sites

4 Likes

I got it working. I set Apache’s ports to 2053 and 444, which only required me to configure Cloudflare’s entries with ports using Portzilla and I was able to use discourse-setup.

2 Likes