Webhook Paused - Failed Request - Worked before

I’m getting this, suddenly, after working fine for a long time:

No recent changes. I just clicked ‘retry’ while the forum was 100% up and nada, just +1’d the error.


@dylanh724 Did you figure it out?

1 Like

i have exactly the same issue suddenly.

please advise how i can troubleshoot this


That webhook URL is wrong. That is why you get a 302. Please follow the docs at Configuring Patreon integration with Discourse

What is the Status code of the response? Anything in /logs ?


Deprecated hooks return 200
other hooks just not show anything see

here is log:

Thanks in advance!


That is a backtrace but no error. Is there any error reported in the /logs?

1 Like

nothing really related to patreon or webhook urls

here is how it looks like

strange enough, last time i just recreated webhook and it worked some time

Weird enough, it will not give me resume webhook and continue report errors.
what will be best way to debug this?

Did you fill the setting patreon creator discourse username correctly?

1 Like

i was under impression that this setting is only if you use social login with patreon
let me add it and recheck

added it. still webhook reports failures

Ok, no solution, seems plugin is broken badly.

It’s working fine for all our hosted customers.

Hi Jeff. Yes it works during some time and then webhook will throw errors similar to that from topic starter and mine.

Still throwing errors after it was setup fine earlier. An update must’ve broken it?


If it it was wrong (not saying it isn’t), why do we have auto-setup Patreon groups with folks in it from earlier? Was this guide changed? Not sure where else I’d get the url from.

Could gem updates have broken this @Falco? :thinking:

1 Like

Wait, I got it working by changing the URL webhook URL (and updating the new webhook secret).

I swear the docs showed a different URL - I copy and pasted it from somewhere (could never have guessed). It worked for a while, then stopped. Maybe there are 2 guides somewhere where 1 is deprecated?