Website shows if I type IP, but not if I type site name

Hello, i’d firstly like to apologise for the the lack of detail in the title and the lack of detail that’ll be in the post. I’m new to all of this and I have no idea what I’m doing.

Basically yesterday I made a digitalocean account, and I setup a droplet, followed the creation process to make a discourse site, however the site only shows when I type the IP address into the URL bar, if I type the hostname, I either get an error saying the website cannot be found or ERR_NAME_NOT_RESOLVED.

I’ve tried using a personal website that I bought and never used, and I tried using the domain Nothing seems to be working, like I said I can access the website and admin settings when I enter the IP into the URL bar, but not if I type the hostname in.

I’ve tried a lot of google searches and I can’t figure out what’s wrong, it’s probably a simple fix but I like I said i’m only 17 and i’m new to all this, so I honestly need the simple answer.


Did you create a DNS A record for your subdomain and pointed it to your droplet IP?

I don’t see a valid A or AAAA record associated to your domain.


A DNS lookup shows:

No match for domain "CRAFTLADS.COM".                             

So you either haven’t registered that domain or you typed it wrong here.

And if you haven’t configured DNS for the domain you also haven’t gotten mail configured, so Discourse won’t be able to send mail.

If you’d like help getting things set up correctly, see Discourse Installation Packages – Literate Computing, LLC