Welcome message for approved users incorrect

Hi,

(I do not know if it is a bug or just a support case, please move it to the correct destination if bug is not the correct category)

today one of our new registered users did complain that our email welcome message was partially in English even though is should have been completely in German.
Only the “%{new_user_tips}” section in the middle of the email message is in German.
The weird thing is, I cannot find the English text in any email template in the admin interface:
admin/customize/email_templates/
Only one template is very similar user_notifications.signup_after_approval but that is in German and the middle part is a little bit different.
And I also searched for “staff member approved” in the admin interface where all text inside the forum can be changed but nothing was found.

So where is the english text coming from in the email message and where can I change it?

Here to visualize the problem the email message that was sent by the system (marked in bold the english text)

Welcome to Marktplatz der Ideen!

A staff member approved your account on Marktplatz der Ideen.

You can now access your new account by logging in at:

If the above link is not clickable, try copying and pasting it into the address bar of your web browser.

Wenn Du gleich in die Welt von DiB eintauchen magst, siehst Du hier was gerade diskutiert wird, und hier findest Du eine kleine, erste Übersicht zu Ansprechpartner/innen, Funktionen und Dokumenten.
Bitte beachte dabei unsere Nutzungsbedingungen.

Du hast weitere Fragen? Dafür haben wir unser “Marktplatz-Patensystem”. Schreib einfach eine Nachricht an Simon Filser (in seinem Profil oben rechts auf “Nachricht” klicken). Er wird Dir dann eine persönliche Kontaktperson zuweisen, die Dir hilft, Dich bei DiB zurecht zu finden.

Schau doch mal in Deinem Landesverband vorbei! Die Leute vor Ort freuen sich darauf Dich kennen zu lernen. HIER ist zum Beispiel der LV Hamburg; in der gleichen Kategorie findest Du auch die anderen 15 Landesverbände.

Wie Du direkt jemandem eine persönliche Nachricht schreiben kannst, lernst Du hier. Wenn Du Dein Profil anpassen möchtest, findest Du hier ein Anleitung.

Für einen respektvollen Umgang miteinander haben wir uns diesen Verhaltenskodex und dieses Regelwerk gegeben. Um diese stets hochzuhalten, bitten wir Dich diesen Hinweis der Moderation zu lesen.

  • Das eigene Ego hinten anstellen – DiB gehört keinem.

  • Beim Gegenüber stets erstmal davon ausgehen, dass er*sie es gut meint – wir sind alle im selben Boot.

  • Vermeiden von: “Man müsste”, “man sollte”, “jemand anders sollte” – konstruktiv arbeiten mit: “Ich kann”.

  • Alle engagieren sich hier ehrenamtlich – keiner ist ein Dienstleister für die anderen.

  • Es gilt das Initiativ-Prinzip: Wer macht, entscheidet, wie es gemacht wird.

  • Wir sind eine wandlungsfähige, lernende Organisation – gute, neue Ideen sind stets willkommen.

  • Frage Dich immer vorher: Ist mein Beitrag jetzt an dieser Stelle wichtig, bringt er wirklich etwas Neues ein, was die Diskussion vorwärts bringt?

Wir freuen uns auf Deine Ideen!

Dein DiB-Marktplatz-Team

We believe in civilized community behavior at all times.

Enjoy your stay!

is it a bug or just a support case?

I don’t know, but maybe this will be some help.

What the content should be is

but what it is

but with the %{new_user_tips} in Deutsch

I’m guessing there was some mixup with editing various text in the UI and the locale setting at some time.

3 Likes

well as far as I can tell the locale has not been changed since the first setup.
When I try to change the default locale now from “Deutsch” to “English” I do get an error:


and the log says:

NoMethodError (undefined method `include?' for nil:NilClass) /var/www/discourse/lib/site_settings/type_supervisor.rb:172:in `validate_value' 

I checked both files mentioned by Mittineague and both do have the correct content.

Therefore now the question, where is the information stored that for this message the english version is used with the german %{new_user_tips}?
How can I change it so that always the data from server.de.yml will be used?

Can you verify this is working @gerhard?

1 Like

The mixture of German and English in the email was caused by an error in the German translation. I created a rake task to detect such problems. Tomorrow I’ll post in #dev:translations about it, since it can help translators with finding problems in their translations.

Anyway, I fixed all the problems in the German translations, so this particular bug should be fixed.

That problem was fixed a few weeks ago.

5 Likes