What causes a message to be posted while the attached files haven't finished uploading?

I’ve seen this behavior multiple times on my forums:

A user posts a message in which the uploads weren’t finalized.

I tried to reproduce the issue by sending a message when my uploads were still uploading, but it won’t send the message until the upload finishes, as expected.

In which cases this issue may happen?

1 Like

This normally occurs when your browser is still attempting to get the image itself, it should automatically change to the real picture within a few moments.

I think if you click the reply button too quickly (or while the image is loading), it will end up doing this issue. On my end, I can’t click Reply until it is done uploading.

Exactly how I tried to produce it just right now.

I bet it is because of an issue of upload, not emailing, and those images aren’t uploaded to forum at all. It happends to me all the time, if that batch is someway too big. I don’t know if there is lack of some unicorns, cores, RAM, cache, swap… but it happends and everytime when images are too big, like directly from a phone. That has been an issue all the time.

And has happened here too when I tried, something like a year ago — but I had something more relevant to do and I didn’t bother start a bug topic, If I’m remembering right :wink:

Because nowadays I’m uploading smaller images or smaller batches (max 2 images) I can live with it.

And yes — that can be a new issue too, of course.