Why does install hang on background saving?


(flexihack) #1

I recently installed Discourse on DigitalOcean (1GB CPU) and then when I try to rebuild the site it takes about 15 minutes (not even complete yet). It’s currently on something like “Background saving terminate with success”


(Jeff Atwood) #2

It takes around 8 minutes the last time I checked. The delay is that’s how long Rails pipeline takes to compile assets.


(Sam Saffron) #3

Note, Btrfs is going to knock off 1-3 minutes of this process


(Michael Pavey) #4

It’s taking me much longer too unfortunately. I’m using a 1GB DigitalOcean box, and the last message was 24 minutes ago. It reads:

[181] 08 Oct 11:49:32.263 * Background saving terminated with success

(Michael Pavey) #5

Just FYI, I gave up, dropped the SSH connection, reconnected, tried stopping the app and rebuilding again, got an error message that postgres was already running, followed the instructions I found elsewhere on this forum to reboot, then did a rebuild again and it completed fine within about 3-4 mins.


(Michael Downey) #6

This happened to me the other day as well when I was moving from the beta to tests-passed channel. Very “buggy” at least appears that way, and creates quite a bit of downtime when you have to make 2 or 3 attempts at it. Perhaps the messages could be more verbose so people know things are happening in the background?

Update: Was just upgrading to 14.04 LTS and the same thing happened as described above. Had just rebooted after upgrading the OS, and 20 minutes into the bootstrap process, it was hanging at * Background saving terminated with success for 10+ minutes. I rebooted, and tried to bootstrap again. This time it hung several minutes after updating /etc/nginx/conf.d/discourse.conf with SSL information. Another reboot and re-bootstrap, seemed to work, and only took a couple minutes. However when trying to start the app, I got:

2014/10/08 10:49:07 Error response from daemon: Cannot start container 45892ae9d79e85a30ec1b43d597aabc334257bced330972f3477b20a29f9c767: Cannot find child for /app

Following Error response from daemon: Cannot start container [hash]: Cannot find child for /app resolved that, and I’m finally back in business after an hour. :slight_smile:

2GB box at DO.


(Jeff Atwood) #10

No, this is incorrect. That issue has nothing to do with swap file, I see it a fair bit and every install we do has a swap file.


(Tobias Eigen) #11

Could it be related to SSL? I ran into this exact error quite a bit last week while I was troubleshooting problems with SSL.


(Jeff Atwood) #12

FYI @sam recently fixed the issue where the installation would hang late in the process – apparently we were terminating Postgres incorrectly and this would lead to hangs/problems.

To get the new image, you need to log in, git pull at /var/discourse and rebuild.


(Dan Eriksson) #13

I am currently trying to upgrade from 1.1.0.beta4 to 1.1.0.beta6b and I’ve been stuck here for over an hour:

Should I keep on waiting or do something else?


(Régis Hanol) #14

What does the Processes tab look like?


(Dan Eriksson) #15

Like this:

Edit:
And now I can’t get back to follow the upgrade. It says:

And when clicking the “Currently upgrading” button it looks like this:


(Jeff Atwood) #16

Reboot. Log in at console, then git pull and ./launcher rebuild app.


(Dan Eriksson) #17

I did that, and now everything is Okey. Thanks.


(Jeff Atwood) #18

Not really seeing this on discourse.codinghorror.com though which is running btrfs – I always upgrade this site at the same time I upgrade talk.commonmark.org and if anything discourse.ch upgrades consistently slower.


(Jeff Atwood) #19