Why is my upload limit 100mb?It's set to 500mb

I’ve been working on this for 4 days now, but no matter how I set it up, I can’t upload videos larger than 100mb. Every time I get a message that the file exceeds the 500mb limit.

Just curiosly asking, what happens if you set it to 0 instead of 500m?

I mean 0 and not 0m

I’ll try it now.

Does that extra space before semicolon mean something?

I changed it to 0 this time and then set 1000MB on the admin page, rebuild app
uploaded a 101mb video and it still says it’s over 1000MB.

I deleted the space.

The problem now is that video files larger than 100mb cannot be uploaded.
Although Discourse’s file settings are already in effect at 1000mb, the internal logic is actually still limited to the maximum value of the image…

Can you guys test your site, set the other attachment sizes to 1G and try uploading a 101mb video and see if it uploads?

You have a standard install and do not have a reverse proxy in place?

It is a standard installation, no other reverse proxy is used.
The problem is that the size of other attachments is also limited by the size of the image

So if you increase the max image size you can upload bigger videos?

No, this 102400kb is set by Discourse system, I didn’t set the size of the image, it’s still the default 4096kb, I’ve already set the size of my other attachments to 500mb and it’s also effective, but in fact, when uploading the video, it will still be stuck at the maximum size of the image.

So I’d like you to try and see if there’s a bug in Discourse.

I see that it’s a generic error when the webserver can’t handle the upload size.

It seems to be a good idea to use client_max_body_size 0;, but was nginx fully restarted?

I would ensure upload_size is set to 0 and rebuild the app to clear any changes.

If you are looking to support massive files you need to set up direct to s3 uploads the site setting enable_direct_s3_uploads needs to be enabled for that to work.


I’ve tried turning s3 on and off and can’t upload files over 100mb.

I tried deleting Discourse and reinstalling it to restore the data. Still can’t upload files over 100m.

Is the above setting enabled?

I’ve set it up so that even small files can be synchronized to the s3.

Where do I set it? I can upload large files. But the large files are local and not synchronized to s3.

It’s a hidden setting, open a rails console

cd /var/discourse/
./launcher enter app
rails c

and do

SiteSetting.enable_direct_s3_uploads = true

1 Like