Wordpress Plugin - Error Curl 60 - Unable to verify certificate

Hi Guys!
I’m new here and I’ve just joined the Discourse Family.

today I was trying to integrate a fresh installation of Wordpress with a fresh installation of discourse when I’ve jumped in this weird error:

cURL error 60: SSL certificate problem: unable to get local issuer certificate-

Both discourse and Wordpress use a Wildcard certificate and my discourse is running on a subdomain, and Wordpress run on the main domain.

Discourse is installed inside an ubuntu VM on my Esxi server and I did that via quick setup.

Discourse don’t present any problems at all, and I don’t really understand where the issue is with the CA.

Looking online lot of people suggested to add a reference in php.ini with the local .cert, and I’ve tried that but it didn’t work.

Both Wordpress and Discourse are on HTTPS, and discourse is on “Forced HTTPS”

What should I try to do to fix this issue?

Any Suggestion?

This doesn’t appear to be a Discourse issue, more of an issue with your SSL cert setup and curl … not sure we’re the right place to help on this one.

Yeah, I’ve tried most of things already but can’t find the right way around it… I hope that someone else might have jumped inside this weird issue…

This could be an issue with your Discourse installation.

This error means that your Wordpress is unable to verify whether Discourse’s SSL certificate can be trusted.

There can be two possibilities:

  1. It’s WP’s fault: your Wordpress server does not have an up to date list of trusted certificate authorities. Settings error SSL certificate problem: unable to get local issuer certificate | WordPress.org

  2. Discourse is not configured correctly - the web server does not present a correct certificate chain. Does your Discourse installation pass the SSL test? SSL Server Test (Powered by Qualys SSL Labs)


Hey Richard, thank you for the reply.

I was doing some research, and the only thing I can think about its my network configuration.
My discourse is behind a reverse proxy inside a VM.

I’m using HA Proxy and doing some research im not the first having this type of error on a website publishes behind a Reverse Proxy using HTTPS.

Im doing some researches now and I might have a guess on what might be…

I’ll keep you guy posted!

1 Like

Did you ever fix this issue?