Worked and now can't even rebuild

Right now I can’t even build in a new directory.

2023-02-27 01:18:46.421 UTC [42] LOG:  database system is shut down

Pups::ExecError: cd /var/www/discourse && sudo -H -E -u discourse git fetch --depth 1 origin tests-passed failed with return #<Process::Status: pid 144 exit 128>
Location of failure: /usr/local/lib/ruby/gems/3.2.0/gems/pups-1.1.1/lib/pups/exec_command.rb:117:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"code", "cmd"=>["sudo -H -E -u discourse git reset --hard", "sudo -H -E -u discourse git clean -f", "sudo -H -E -u discourse git remote set-branches --add origin main", "sudo -H -E -u discourse git remote set-branches origin $version", "sudo -H -E -u discourse git fetch --depth 1 origin $version", "sudo -H -E -u discourse git checkout $version", "mkdir -p tmp", "chown discourse:www-data tmp", "mkdir -p tmp/pids", "mkdir -p tmp/sockets", "touch tmp/.gitkeep", "mkdir -p                    /shared/log/rails", "bash -c \"touch -a           /shared/log/rails/{production,production_errors,unicorn.stdout,unicorn.stderr,sidekiq}.log\"", "bash -c \"ln    -s           /shared/log/rails/{production,production_errors,unicorn.stdout,unicorn.stderr,sidekiq}.log $home/log\"", "bash -c \"mkdir -p           /shared/{uploads,backups}\"", "bash -c \"ln    -s           /shared/{uploads,backups} $home/public\"", "bash -c \"mkdir -p           /shared/tmp/{backups,restores}\"", "bash -c \"ln    -s           /shared/tmp/{backups,restores} $home/tmp\"", "chown -R discourse:www-data /shared/log/rails /shared/uploads /shared/backups /shared/tmp", "[ ! -d public/plugins ] || find public/plugins/ -maxdepth 1 -xtype l -delete"]}
bootstrap failed with exit code 128
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.
==================== END REBUILD LOG ====================
Failed to rebuild app.

That’s not the error. As the message you pasted says the error is somewhere further up.

1 Like

I’ll look again but I saw some warnings. All I could get out of it was git was having issues. I moved the old directory aside and tried again.

fatal: unable to access '': Could not resolve host:

root@main:/var/discourse# ping
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=50 time=42.7 ms
64 bytes from ( icmp_seq=2 ttl=50 time=42.7 ms
64 bytes from ( icmp_seq=3 ttl=50 time=42.7 ms
--- ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 42.650/42.671/42.696/0.018 ms

If these requests are being made from inside the container I suppose it could be a proxy problem but it worked before. Maybe made too many changes on the system to know now. Proxy should be the same as it was though.

EDIT: But it built and ran before I had the Proxy configured correctly so, just don’t know.