WP Discourse 1.2.5 Release


(Simon Cossar) #1

The latest release of the WP Discourse plugin (1.2.5) is available on the WordPress plugin repository or on GitHub.

Most of the changes in this release have to do with reorganizing the admin code to allow other plugins to extend the wp-discourse plugin and use it’s options pages. There is an example of that here: GitHub - scossar/wp-discourse-latest-topics: Adds a ‘latest topics’ shortcode to the wp-discourse plugin. It adds a [discourse_latest] shortcode that displays a list of the latest Discourse topics. Topics can be refreshed when they appear on Discourse with a webhook. See the comments in that plugin if you’re looking for ideas.

One useful change in this release is that you can now set the ‘Max Visible Comments’ to 0. This is useful if you would like to have a link at the bottom of your WordPress post to your Discourse forum, but don’t want to display Discourse comments on WordPress. The text for that link can be set in the ‘Start Discussion’ text setting. I’ll change the copy on the options pages a bit to make that clearer.

Another change is that when the plugin is activated on a server with a php version of less than 5.4, it will now, hopefully, give the user a friendly message that they need to update their php version.

One recent change to the plugin that hasn’t been promoted much yet, is that you can now use Discourse to authenticate users on your WordPress forum. Thanks to @iamntz for doing the work on that!


Wp-discourse-shortcodes plugin
(Jeremy M (Jerdog)) #2

Is there any way to use this with WordPress.com hosted sites?


(Simon Cossar) #3

No, not now. After a few more changes are made to the plugin, it would be great it people would start asking them for it. Getting it onto regular WordPress.com sites seems like a long shot, but once the SSO code gets moved into a separate plugin, it should be possible to get it onto sites hosted on WordPress.com VIP.


(Simon Cossar) #4

This seems to have caused a problem. When the plugin is updated from a previous version, it’s being deactivated. I’ll fix that right away.

Edit: I’m still confused by what is going on with this on this. It’s not an easy thing to test. I’ll come up with a solution as early as possible tomorrow.

Further Edit: it turns out there isn’t a problem with the update process. I was just doing something dumb in the way I was testing it. :stuck_out_tongue: