Discourse comments aren't visible after update


(Daniel) #1

Hi!

I left my Wordpress blog unattended for a while. When I came back and updated it, I noticed that discourse comments aren’t shown anymore beneath the posts. Newly published posts have text “Continue discussion at Disocurse…” and no comments. Older posts doesn’t have event that. Everything else is working as it should.

I’m using WP Discourse plugin from the day I launched this blog. I have enabled Hueman theme. I tried switching to the one of default WordPress themes, but it didn’t do any good.

What could be the cause of this problem?

Thanks for any help!


(Simon Cossar) #2

Do you know what version the WP Discourse plugin was at before you updated it? If you create a comment for a newly published post, does it show up on Discourse?


(Daniel) #3

Unfortunately I`m not completely certain. It could have been 1.5.3. or a bit older version.

Actually it appear that I can’t make comments at all. Wordpress comment field just doesn’t show up.
Prior to that I enabled commenting in WP settings and WP-discourse plugin settings.


(Simon Cossar) #4

That should be fine.

Can you send me a link to your WordPress site, either on here or on a private message? I’ll take a look and see if there are any obvious problems.


(Simon Cossar) #5

If you have the Sync Comment Data webhook enabled, could you try disabling it and see if that makes a difference. If the webhook isn’t working for some reason, it can prevent comments from being updated.

Do you have any security plugins on your WordPress site? If so, make sure that requests to your forum are not being blocked.

It is also possible there is a conflict with page caching on your site. If you have any caching setup, could you try enabling the Load Comments With Ajax setting? It is found on the WP Discourse Publishing tab.


(Daniel) #6

“Start the discussion at …” under the topics disappeared.

No I don’t.

No I don’t, but I still tried switching on Load Comments With Ajax setting. No effect.


(Simon Cossar) #7

I see the ajax comments template on your site now, but with no comments. Could you disable that setting, keep the webhook setting disabled as well, and wait 10 minutes for the cache to clear on the Discourse comments? See if the comments are then able to load.

You could try disabling plugins one by one on your website to see if there is a conflict with any other plugin.


(Daniel) #8

I don’t see any change.


(Simon Cossar) #9

One way to check if the update is causing the problem would be to upload version 1.5.2 from the Previous Versions select menu at the bottom of this page: WP Discourse — WordPress Plugins. To install it you will need to deactivate and then delete WP Discourse. You will then be able to upload the 1.5.2 zip file. You will have to reconfigure the plugin after installing it.

If you try this, please let me know if it works for you.

Edit: I’ve tried the latest version of the WP Discourse plugin with the latest version of the Hueman theme and Hueman Addons plugin. It’s working for me as long as I have comments enabled through the theme customizer. If I don’t have comments enabled, I get results similar to what you are getting.