WP Discourse 2.4.8: possible bug with excerpt function

Hi there,

I’m using WP Discourse (2.4.8). Under the “Publihsing” tab, I unchecked Publish the full post to Discourse, rather than an excerpt. Publishing posts works and an abbreviated representation is displayed in Discourse. However, when I update a post and select the Update Discourse topic function, the post does not update or submit the changes.

However, if I enable the Publish the full post to Discourse, rather than an excerpt. function, then updates also work, or the Update Discourse topic function works correctly.

Maybe a bug?

Thanks for the report! I’ll take a look at this soon.

1 Like


For your information: Only the excerpt length/part of the texts gets updated.

1 Like

@angus Any updates on this?

I’ve tried to reproduce this a few times, but haven’t been able to. Here’s an example of such as test (i.e. it’s working as expected)

Note that “Use Full Post Content” is disabled.

Are you sure you’re saving the Wordpress post first?

I’m only posting from WordPress to Discourse. So yes, I am sure that I am saving the WordPress post first. Maybe it’s not happing with short texts. Could you try it with longer texts like 1500 words and more?

I’ve tried this a few more times with texts of various length and it works every time. For example

Could you please double check the following:

  1. Look at the logs for WP Discourse. Turn on verbose publishing logs if you don’t have them on already.
  2. Look at the logs for your Wordpress.
  3. Try disabling other plugins and themes.
  4. If you’re using any custom functions that interact with WP Discourse please post them here.