Wrong domain name extension in welkcom email


(Jaya Kuipers) #1

I’ve installed an discrouse on an digitalocean droplet and setup email with mailgun.
Everything works well.

But new users get an email with an wrong baseurl.
the domain extension should be .nl for my installation but it says .com

Can somebody point me out how to change this?
I’m quit new with linux so a stepguide would be great.

My intention is to test discourse for a couple of months in this way and upgrade to an paid account after that.

Kind regards!

Jaya


(Joshua Rosenfeld) #2

Check site settings. What is the value of notification email?


(Jaya Kuipers) #3

Hi Joshua,

The notification email is this "postmaster@netwerk.highimpactteaching.nl"
Check the email I’m getting:
example — imgbb.com

it’s from a .com
but the sender is .nl
and the baseurl is wrong


(Joshua Rosenfeld) #4

Ah! The email address does correctly use .nl, it’s the site domain that is incorrect.

Let’s check your app.yml:

  1. SSH into your server, logging in if requested.
  2. Type cd /var/discourse followed by Enter
  3. Type sudo nano containers/app.yml followed by Enter
  4. Using the arrow keys, navigate down in the file until you find DISCOURSE_HOSTNAME: - check the value there.
    1. If it’s incorrect (using com not nl), update it, still using the keyboard only.
    2. After updating it, exit the file by typing Ctrl + x, save by typing y, then hit Enter to keep the same file name.
    3. Finally, run sudo ./launcher rebuild app to update your site with the changed hostname.

(Jaya Kuipers) #5

thanks @jomaxro you are my hero today!

It’s pretty straight forward these steps to fix a simple thing :slight_smile:


(Jay Pfaffman) #6

Those who want to avoid dirtying their hands with a text editor can just run disourse-setup again. It’ll stop the running discourse, re-read the settings using current settings as defaults, and rebuild.


(Jeff Atwood) #7

Yeah I wouldn’t recommend this complex set of steps, over “re-run the setup script”.


(Joshua Rosenfeld) #8

I need to remember that! I’m too “old school” - I keep recommending manual edits and site setting searches instead of the setup script and the wizard :sweat_smile:.


(Jay Pfaffman) #9

I totally get it. Had I not spent a bunch of time writing discourse-setup, I’d tell people to use vim the way God intended. :slight_smile:

And, your answer worked, so there’s that.