Wrong images displayed on screen overlay


(Christoph) #1

On Android, discourse sometimes displays the wrong images when navigating through multiple images in a post (in the screen layover that pops up when tapping an image).

In this post, for example, I get several images from the stock material theme instead of the daemonite ones included in the post:

Repro … click [image] above :arrow_double_up:


(Jeff Atwood) #2

Can you repro @tgxworld?


(Sam Saffron) #3

Easy repro, happens when oneboxing a local topic containing images


(Christoph) #4

Hm, I can’t repro this by clicking on [image] above. I can only repro by actually visiting the topic and clicking on an actual image there. (BTW: it’s not specific to mobile but also happens on desktop)


(Sam Saffron) #5

It is a repro, the issue you are seeing is that “quoted” images are in the carousel.


(Christoph) #6

Ah, I see. The this issue is perhaps a bit more complicated than I thought, because I think it’s not a bad idea to have quoted images pop up when you click [Image]. So would it be possible to have that without adding them to the carousel? Perhaps there could be a separate carousel for each post?


(Sam Saffron) #7

its quite a simple fix, [image] really should not be a hyperlink.


(Christoph) #8

So if you remove the hyperlink, that fixes it? Aren’t the images just hidden and will nevertheless be in the carousel?

If you remove the hyperlinks, what will happen when I unfold the quoted post, revealing the images? Will the then be in the carousel but disappear again when I collapse the quote again?