Yandex email error: Email sending without SSL/TLS encryption is not allowed

Hi, I have an error saying 530 5.7.7 Email sending without SSL/TLS encryption is not allowed. Please see: https://yandex.ru/support/mail/mail-clients/ssl.html while running ./discourse-doctor.

However, with same config, I can successfully send email with swaks.

swaks --to me@gmail.com --from mailbox@domain.com --server smtp. yandex. ru --auth LOGIN --auth-user mailbox@domain.com -tls -p 587

My app.yml settings:

DISCOURSE_SMTP_ADDRESS: "smtp.yandex.ru"
DISCOURSE_SMTP_PORT: 587
DISCOURSE_SMTP_USER_NAME: "mailbox@domain.com"
DISCOURSE_SMTP_PASSWORD: "password"
DISCOURSE_SMTP_ENABLE_START_TLS: true           # (optional, default true)

I tried all suggested solution in the forum but it does not work. Maybe @Stranik know how it works?

Much appreciated everyone’s thoughts.

2 Likes

I tried MailJet and it did not go through with ./discourse-doctor neither. However, the test with swaks works just fine.

Maybe:

E-mail domain must be registered (served): https://pdd.yandex.ru/

E-mail address in: notification email (admin/site_settings/category/required) and DISCOURSE_SMTP_USER_NAME (app.yml) same.

The user (his email address) is in the settings, and there is an account of this user on the forum. This user has a Yandex mail. And the mail itself is served by Yandex.

I have done this, it seems to work.

In Yandex, you must actually create a mail domain. Confirm the rights to it, and set all the necessary settings.

To be honest, I don’t fully understand how this works. It’s too complicated. )

I did register domain and create the email. I can use that email for other purposes. I’ve done that before, so I’m sure domain ownership verification and email creation is working correctly.

1 Like

I tried Sendgrid yesterday and it did not work. And again, testing email sending with swaks works just fine. I’m starting to think if there’s a bug in current version. I’m using iscourse 2.6.0.beta2. I followed the installation scripts in Docker hub page:

sudo -s
mkdir /var/discourse
git clone https://github.com/discourse/discourse_docker.git /var/discourse
cd /var/discourse

I think probably the beta is breaking. How do I install the latest stable version?

I looked at the log file after hitting resend verification email and got this: Delivered mail a6148e37-bccc-4c05-9987-7fb867a4f369@domain.com. I’m not sure if it’s the problem but my email look like this test@domain.com.

@codinghorror can you please have a look? Major email services (Mailjet, Sendgrid, Yandex) failed with this build. But the emails all go through with swaks --to me@gmail.com --from mailbox@domain.com --server smtp. yandex. ru --auth LOGIN --auth-user mailbox@domain.com -tls -p 587.