429 Too Many Requests - IP logs disabled - discourse can see 127.0.0.1 only

For privacy, GDRP compliance, data collection minimization purposes, I’ve disabled IP logs on my server. Discourse doesn’t get to see any IP addresses.

      proxy_set_header X-Real-IP 127.0.0.1;
      proxy_set_header X-Forwarded-For 127.0.0.1;

This is confirmed using discourse admin. No IPs can be seen for my user profile in admin mode.
Is discourse behind a reverse proxy? Yes. Behind nginx.

Also my forum has an onion domain mirror where it would be impossible to get any IP addresses.

That used to work great but now I am getting more and more error messages.

429 Too Many Requests

I guess discourse uses some kind of IP based rate limiting? But shouldn’t that exclude 127.0.0.1? How to disable this kind of rate limiting?

1 Like

Remove the web.ratelimited template at the top of you app.yml file and rebuild.

6 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.