Discourse-topic-organizer causing "Slow down, too Many Requests from this IP Address"

We installed one plugin in our discourse platform. but suddenly page shows “Slow down, too Many Requests from this IP Address” . it seems we need to change discourse ngnix settings. is there any solution to this problem ?

Would you mind sharing the name of the plugin? That would help see or know what can be done.

3 Likes

Are the ip addresses coming from the actual user ip addresses or do they appear to come from a reverse proxy?

1 Like

I also saw this recently for the first time when opening up several tabs from links on a page. We have just moved the site to being a local nginx reverse proxy to provide for a maintenance splash page.

(Perhaps the user’s origin IP is not being passed to Discourse somewhere? Or maybe this isn’t the issue at all and it’s just a coincidence.)

See Global rate limits and throttling in Discourse.

If you open multiple tabs or if you have a corporate IP (or even just two or three users working on the same internet line), it is easy to hit the rate limit.

2 Likes

Yup. And since then every IP is that of the reverse proxy.

That’s my guess. It’s probably logging the reverse proxy for all IPs. Look at the “how to run with other web server” topics for tips on getting the correct IP to NGINX/Discourse.

You can check by looking at a couple of recent user IPs and/or looking at /var/discourse/shared/standalone/logs/var-log/nginx/access.log (or something very much like that).

Hmm, that seemed right, but loooking at the “internal” nginx access logs shows the real IP’s being passed through. :man_shrugging:

1 Like

Too bad. That was the easy solution.

Some plugins and theme components can generate lots of requests. Or maybe you just opened a zillion tabs and you caused this problem yourself. :wink:

below i mentioned plugin url of github. GitHub - siddhudhangar/discourse-topic-organizer

if any suggestions are there then let us know.

Request is coming via reverse proxy but I have white listed IP address of proxy in discourse “screened_ip_addresses” settings.

I am also having this problem. So is one of the moderators of our site.

Do you also have the discourse-topic-organizer plugin @outofthebox?

It looks that plugin creates a lot of ajax calls when the app boots. That is very likely to trigger the rate limiting, especially when there are lots of categories. (cc @Siddhu_Dhangar)

4 Likes

Good question! I don’t have that plugin installed.

1 Like

In that case, I recommend trying safe mode to rule out any custom plugins. If it persists, let’s open another #support topic, since it’s probably a different cause

6 Likes

have you found any solution on this problem ???

The discourse-topic-organiser plugin is creating too many Ajax calls - it needs to be made more efficient

3 Likes