502 Bad Gateway - failed to update


(Mực Tàu) #1

Hi guys!
I got failed during upgrading process from the admin. And then I tried to rebuild again, but I face constant problem:

Layer already being pulled by another client. Waiting.

Someone please help me :frowning:


(Jeff Atwood) #2

Not sure, try rebooting. Or waiting a while.


(Mực Tàu) #3

Rebooting does not help. I leave it for 12 hours and then get no difference :frowning:


(Sam Saffron) #4

Try uninstalling docker and reinstalling latest


(Jeff Atwood) #5

Good idea try docker --version and docker --info as well.


(Mực Tàu) #6

@sam, @codinghorror
The system automatically generate the app.ml.save, and the app.yml becomes empty totally.

I deleted the app.yml, then transfer an original app.yml. And then it becomes empty with the size of 0.
I try nano containers/app.yml to modify it. After adding the content, it can not be saved by the error of “No space left on device”

Please help me guys @@


(Joshua Rosenfeld) #7

The error in nano says “No space left on device”. Have you checked that you haven’t run out of disk space?


(Mực Tàu) #8

Of course! I still have more than 10Gb of available disk :frowning:


(Joshua Rosenfeld) #9

Well, that’s all I’ve got. I would recommend that you run docker -- version and docker --info for @codinghorror though, the results can be very helpful for them to see what is going on.


(Kane York) #10

What does the df -h command return?


(Mực Tàu) #11

@codinghorror, @sam, @jomaxro
I just want to let you guys know that the problems were solved by resizing my server for larger ram and disk.
Thank you so much for kind helps :slight_smile:


(Jeff Atwood) #12