Ads showing to Trust Levels that should not see them?

I’m at a bit of a loss here. My desired outcome is to not show ads to anyone logged into the forums. Currently I am only set for adsense ads, no in-house yet.

Despite configuring trust levels and so on to prevent ads being seen by logged in users, some are still seeing them.
Actually add me to the list as admin too I’ve even seen them in the admin panel and general browsing.

Problem is that I cannot find a pattern to it.

It’s intermittent for the users.
There doesn’t seem to be a consistent browser/OS involved
It’s impacting various trust levels. :man_shrugging:

Any ideas where I can look next to see what could be causing this? One thing I should mention is that I’m using cloudflare in front of the forums.

As I type we’re on latest discourse and ads plugin.

Appreciate any help.

Change to dns only and I bet that problem is solved.

1 Like

Really good point.I did clear the CF cache at the outset, but will give this a go and report back. I know I don’t have all CF features turned on, especially the ones with JavaScript wizardry.

But will try dns only or developer mode and see how it goes.


1 Like

OK well that’s weird… DNS only seems to stop the website from loading. I’ve toggled back and forth between DNS only and proxied and it only loads when the forums subdomain is set to proxied…

For fun I tried my cable and cell internet connections and got the same result

Did you do a standard install?

It’s loading for me now . . . oh but you switched back to cloudflare.

1 Like

I’m pretty sure it was a standard install, I did it 7 years ago or so following the Ubuntu guide at the time which at that stage I think it was installed 18.x LTS. It’s on Ubuntu 20LTS + Docker as I type now.

Yes I switched back to proxied but with all minification disabled. No change.

Update: Turned off caching for the subdomain with a page rule. We’ll let that percolate for a while.

1 Like

Update… I’m personally still seeing (some) ads inside the Discourse Hub app and native Safari on iOS. Mostly bottom of page ads (Including the admin panel!) but also a top page one after logging in. CF caching is still disabled.

Checking in with the community to see where we’re at otherwise.

Does your install have Let’s Encrypt enabled, or are you only doing HTTPS encapsulation between CF and the server?

1 Like

I believe cloudflare is handling SSL between edge and browser, but it may be plain between the discourse server and cloudflare.

The site won’t load fully if I enter the IP directly into the browser if that helps?

IP based access isn’t supported.

Your browser will remember that the site uses https, so if you turn the orange cloud off and try to connect to the url via HTTP it’s going to fail.

I would fix https at this point, let’s encrypt is free and very reliable.

You’re going to need to update your app.yml and rebuild with the Orange cloud disabled to do that, though.

Got it. It’s been a long time since I tried just the IP, at that point it did work, but it was years ago

There’s a plug-in I want to install so I’ll address that and let’s encrypt.

All that said, do you think the SSL setup is causing these issues with the ads?

Since it’s been so long since your install, you don’t have let’s encrypt, so your site can’t work without cloudflare.

I would recommend spinning up a new VM and re-installing then you can switch over. If you really love that machine for some reason, you can rename app.yml and run ./discourse-setup to get a clean install that will get you a let’s encrypt certificate.

1 Like

OK sounds like I’ll have to tackle lets encrypt separately.

Ads are still appearing for logged in users today. Any thoughts on other things I can check?


Also, is DFP the only way to get google ads to appear between topic in topic lists?

You need to fix CloudFlare to ensure it’s not serving cached pages which include ads.

1 Like

All caching has been turned off for over 24hrs now.

I think that conclusion is a little premature. The issue persists despite caching being disabled in CF for about a week now. Unless it’s something else in CF that you suspect is the issue?

1 Like

Oh. Darn.

And you don’t have any plugins?

I do have plugins. I’ll circle back on our original topic later this week.

1 Like