After attempting to install plugin, Discourse no longer loads (Phusion Passenger Cannot Start the web application)


I was attempting to install a Discourse plugin for my forums and upon doing so, Discourse completely stopped working due the plugin installation breaking Phusion Passenger not working.

I followed this guide when installing the plugin: Install plugins

When you visit you receive the following error page:

pastebin com/ Ft0cAWNC


pastebin com/ uBxs6vJ3

I am unable to upload a log file so I have provided the log below the error message. The pastebin links are missing a dot and have a space before the slash because “new users cannot upload more than 2 links”. Thank you to anyone who decides to help me get this fixed :heart:

Hey Josh, how was this instance installed?

Hi, I used this here: AWS Marketplace: Discourse(R) packaged by Bitnami

Please note that it was working perfectly until I ran these commands(trying to install plugins) pastebin com/uBxs6vJ3 by following this guide: Install plugins

I’m afraid we can’t offer support for the bitnami packages here. They’ve been created by a third party and issues like yours aren’t uncommon. If you want to continue using them I would recommend you reach out to the creators of the package.

The free assistance offered here focuses on the standard install, which is very straightforward and can usually be completed in less than 30 minutes.


is there a way to like move files from one sever to another like just from the backend since I cannot access the front end?

If you can access the filesystem and have taken a recent backup, then you can restore from said backup.

1 Like

becuase the normal way looks just like the other way but just installing the package and the normal discourse config so it doesn’t look bad

i have not taken a backup :c

Is this a new site? Is it active? What specifically would you be looking to preserve?

I am looking to preserve members without having to reinvite people

If I can just preserve the members then I am good to reinstall it

1 Like

Yeah, I was not able to figure it out so I created a forum using the official installation method and it worked! I am still trying to get it to work with mailgun. Also made sure to backup both the discourse backup and the disk backup!

If you have any suggestions to help me improve it, please LMK!

1 Like