Install discourse failed due to Custom Wizard plugin

Hello, I had a problem in the process of installing discourse. Please give me some guidance.

What installation guide are you following or using to do this?

Discourse安装 · 语雀 《Discourse安装》

I can confirm the same issue with launcher rebuild app

Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' failed with return #<Process::Status: pid 1590 exit 1>
Location of failure: /usr/local/lib/ruby/gems/2.7.0/gems/pups-1.1.1/lib/pups/exec_command.rb:117:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"db_migrate", "cmd"=>["su discourse -c 'bundle exec rake db:migrate'"]}
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one.
I, [2022-02-08T11:37:45.974947 #1]  INFO -- : > cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate'
rake aborted!
Gem::LoadError: can't activate request_store-1.5.0, already activated request_store-1.5.1
/var/www/discourse/lib/plugin_gem.rb:24:in `load'
/var/www/discourse/lib/plugin/instance.rb:765:in `gem'
/var/www/discourse/plugins/discourse-category-lockdown/plugin.rb:11:in `activate!'
/var/www/discourse/lib/plugin/instance.rb:671:in `instance_eval'
/var/www/discourse/lib/plugin/instance.rb:671:in `activate!'
lib/discourse.rb:279:in `block in activate_plugins!'
lib/discourse.rb:276:in `each'
lib/discourse.rb:276:in `activate_plugins!'
/var/www/discourse/config/application.rb:324:in `block in <class:Application>'
/var/www/discourse/lib/plugin_initialization_guard.rb:5:in `plugin_initialization_guard'
/var/www/discourse/config/application.rb:323:in `<class:Application>'
/var/www/discourse/config/application.rb:73:in `<module:Discourse>'
/var/www/discourse/config/application.rb:72:in `<top (required)>'
/var/www/discourse/Rakefile:7:in `require'
/var/www/discourse/Rakefile:7:in `<top (required)>'
/var/www/discourse/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/exe/rake:27:in `<top (required)>'
/usr/local/bin/bundle:25:in `load'
/usr/local/bin/bundle:25:in `<main>'
1 Like

This is not very helpful.

The actual error is mentioned somewhere above this.

1 Like

yes, sorry - I add second part about the error.
I will try again without side plugins.

My issue was solved by building without several side plugins.

Actually I think the error is right there.

It looks like you are trying to build with two versions of the same gem. Hence: Gem::LoadError: can't activate request_store-1.5.0, already activated request_store-1.5.1

You need to ask the plugin maintainer using the older version if it’s possible to update to the same version and then they might happily coexist.


I’ve added this piece after his comment. At my first edit there was not enough info.

I’ve turned off
git clone

And it seems to solve the issue. WIll take a deeper look later today.

Thank you!

But it stops you using the plugin. Which isn’t much of a solution. Flag this up in the plugin topic.

1 Like

Yes, It’s just a quick fix. I’m a big fan of custom-wizard and we use it for our members “introduction posts”.

Will need to check deeper later today.

1 Like

FYI Custom Wizard uses: 1.5.0:

1 Like

Yes, I’ve notified them

I’m not experienced with request-store at all - so can’t help with quick PR.
Thank you @merefield

1 Like

Which plugin are you using that uses 1.5.1?

(take a look in plugin.rb for each plugin to determine this, if you don’t know).

My confirmation was a wrong direction - my issue was with external plugin.

Do you have any external plugins in your guide?

I think it’s related to this commit

1 Like

Ah, it’s core, great! Then it’s a no brainer.

However, when using Pavilion plugins, do try to stick to the supported period for upgrades (1st 5 days of month). Upgrading outside this period increases the risk you may not get support until the following period.


Yes, I know - I currenty need several things from the last core upgrades.
And It’s even better for me - will go deeper to understand the structure of possible issues.

Sorry,I still don’t know how to get rid of this error, please help me clarify which path the Gemfile.lock mentioned in this page is located in…

1 Like

Sorry for the pause @vsiryxm
The mentioned issue was about fresh Discourse core update and one of the side plugins (Custom Wizard). It is solved now and authors updated the plugin.

If you don’t use Discourse plugins at all - It’s not related to your problem.

Have you tried official Discourse guide to install pure Discourse?