Community not found in App Android Version 7

android-app

(Ingrid Peters) #1

I just got a message from a user that he is unable to log in to our community using the Discourse app on a Samsung device. Since I use a Samsung phone too, I disconnected and tried to reconnect. I am now also unable to reconnect to the community, I get the message’… was not found’.

We have tried this on different devices, and we’re only having problems on Samsung devices running Android 7.0. Does anyone else have this issue? Any idea what we can do about it?


Add a new site (android) 'was not found'
(Alan Tan) #3

Hi Ingrid,

Can I confirm that you’re referring to pvcrm.trydiscourse.com that was hosted with us?


(Ingrid Peters) #4

Hi. No that was a test for us. We ended up hosting it ourselves, https://community.perfectview.nl/
We just soft launched this week and one of our ambassadors notified me about this.


(Jeff Atwood) #6

Could be DNS settings or ipv6 related, if it is specific to some devices. Hard to say.


(Harm van den Heurik) #7

Hello Jeff, i’m a colleague of Ingrid. I am investigating the problem. Can you please give us more details about the ipv6 settings ? All the Samsung devices we’ve tried have to same problem.


(Jeff Atwood) #8

It was just a random idea, not sure if that’s the cause. But we have seen some really confusing network behavior when devices want to use ipv6 and cannot, but ipv4 is working fine.


(Harm van den Heurik) #9

I’ve enabled ipv6 because it was disabled but that doesn’t help. When we open the url in Chrome it works fine but not in the app. See attached screenshot. (The URL in the screenshot can only be accessed from our local LAN)


(Jeff Atwood) #10

Oh you are referring to the app. Make sure you are on the latest version of Discourse (beta) or the app will not work.


(Harm van den Heurik) #11

Hello Jeff,

According the dashboard we are already using the latest version. See attached screenshot.discourse_version


(Joffrey Jaffeux) #13

Having a look t this, I can confirm your forum has the correct version for this, and it works on iOS. Will try to find what happens on android.


(Ingrid Peters) #14

Thanks Joffrey for looking into this. Just to let you know it seems to be a Samsung specific problem. We were able to connect on an LG and an OnePlus without any problems. But all the Samsung devices we tested were not able to connect.


(Joffrey Jaffeux) #15

Confirmed working on a NOT samsung Android (7.1.2) phone, will try to get my hand on a samsung later in the day.


(Gerhard Schlager) #16

I’m seeing connection issues on my Android phone too.
I think it’s because the sever isn’t responding to HTTP requests. Only HTTPS. I guess there should be a redirect from HTTP to HTTPS.


(Joffrey Jaffeux) #17

Indeed, I was fooled by HSTS but there’s not 301 on non HTTP to HTTPS, could you start by configuring this please ?


(Harm van den Heurik) #18

I’ve just tested if our server responds on HTTP and that works fine. It redirects to HTTPS. See link below (which is HTTP) :

PerfectView Discourse


(Joffrey Jaffeux) #19

No it doesn’t, it’s HSTS (http://classically.me/blogs/how-clear-hsts-settings-major-browsers) auto redirecting you after you visited “https://” first.

If you go there for example: http://www.redirect-checker.org/

and fill in http://community.perfectview.nl you will see it hanging forever


(Harm van den Heurik) #20

I’ve changed our firewall so that it accepts HTTP request to our discourse installation. According to redirect-checker.org the HTTP redirect now works fine but the app still doesn’t work.


(Joffrey Jaffeux) #21

Ok perfect thanks, it was a better change for you site anyways :wink: Now that we are sure this is not getting in our way, I will investigate more later in the day.


(Ingrid Peters) #22

Hey Joffrey, I was just wondering if you found something that could cause this issue. I am not being impatient, just curious. :wink:


(Joffrey Jaffeux) #23

Sadly no, I still can’t reproduce at the moment.

I tried on a samsung Galaxy S5 and it worked (also tried on a Huawei).