Community not found in App Android Version 7

I’m seeing connection issues on my Android phone too.
I think it’s because the sever isn’t responding to HTTP requests. Only HTTPS. I guess there should be a redirect from HTTP to HTTPS.

5 Likes

Indeed, I was fooled by HSTS but there’s not 301 on non HTTP to HTTPS, could you start by configuring this please ?

I’ve just tested if our server responds on HTTP and that works fine. It redirects to HTTPS. See link below (which is HTTP) :

PerfectView Discourse

No it doesn’t, it’s HSTS (http://classically.me/blogs/how-clear-hsts-settings-major-browsers) auto redirecting you after you visited “https://” first.

If you go there for example: http://www.redirect-checker.org/

and fill in http://community.perfectview.nl you will see it hanging forever

4 Likes

I’ve changed our firewall so that it accepts HTTP request to our discourse installation. According to redirect-checker.org the HTTP redirect now works fine but the app still doesn’t work.

1 Like

Ok perfect thanks, it was a better change for you site anyways :wink: Now that we are sure this is not getting in our way, I will investigate more later in the day.

1 Like

Hey Joffrey, I was just wondering if you found something that could cause this issue. I am not being impatient, just curious. :wink:

Sadly no, I still can’t reproduce at the moment.

I tried on a samsung Galaxy S5 and it worked (also tried on a Huawei).

1 Like

Are you running Android V7?

1 Like

Hi, we have done more tests and can reproduce it, however we can’t reproduce it with sites we host, we suspect something wrong in your configuration (probably SSL configuration). We are at our annual meeting for the next week, and I wanted to give you the latest info we have on the subject.

6 Likes

Thanks so much for looking into this Joffrey! That’s good news. Harm is the technical person so he will have to look at the installation. Anything in particular he should check out?

I’d start by comparing the test results of your domain and try.discourse.org at SSL Labs.
Oh, and I’d definitely fix the issue with your certificate chain. You’ll find a warning in the test results…

4 Likes

Hello Gerhard,

I’ve fixed the chain issue (removed the CA root from ssl.crt) but the app still doesn’t work on a Samsung Phone with Android 7.x.

1 Like

It’s working fine for me:

Android 8 on Nexus 6p

2 Likes

The problem can only be reproduced on Samsung phones with Android 7.x. On other Android devices everything works fine.

Hello Gerhard,

The problem is solved. After looking at the SSLLabs results again i noticed a difference between the Android 7.0 handhake. Our site gave ECDH secp384r1 while your site gave ECDH secp256r1. After some googling i landed on the following site:

https://stackoverflow.com/questions/39133437/sslhandshakeexception-handshake-failed-on-android-n-7-0

So there seems to be a bug in Android 7.0. I now changed the line “ssl_ecdh_curve secp384r1” to “ssl_ecdh_curve prime256v1” in “web.ssl.template.yml” and after a rebuild the app started working.

8 Likes

I read some things about samsung needing older ciphers but it was for older phones. Glad you sorted it out!

1 Like

Wow excellent sleuthing! Sure glad that someone created Stack Overflow so we could use it to figure this out :wink:

8 Likes

Thanks everybody for your time and energy! :grinning:

3 Likes

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.