Mobile application does not support forum in subfolder


(Ivan Rapekas) #1

I wonder to connect my forum www.example.com/discuss using Android mobile app. Appreciated to any help.


(Jeff Atwood) #2

Are you sure this is a sub folder issue, because the app has other requirements. Such as your site must be https.


(Ivan Rapekas) #3

Not sure, that subfolder configuration is a root cause… The website has https proxy and the forum has a setting ‘force https’ enabled (so, almost all urls are going with https). Forum is in production mode and accesible via web browsers. Users just reported that they tried Discourse mobile app…


(Jeff Atwood) #12

We think this is a local config problem on your end, but we don’t have a customer site with https on a subfolder available to test. Anyone else running a site with https on a subfolder that can test?


(cpradio) #13

It isn’t on latest, but https://www.sitepoint.com/community/ fails to work in the app (same error as original poster).


(Jeff Atwood) #14

I believe @jomaxro said force_https wasn’t enabled there, though, for some odd reason? I don’t know how you can be on https with that not enabled.


(cpradio) #15

Oh, that I can’t confirm or deny, as I can’t see that setting.


(Joshua Rosenfeld) #16

I’m not sure. Both subfolder customers have SSL enabled but not forced that I can see. Both sites predate me, however, so I’m unsure if SSL is forced elsewhere in the config.


(cpradio) #17

I can say with 100% certainty, you cannot visit Sitepoint’s Discourse instance via HTTP. It will force you over to HTTPS, but I can’t tell you if that is setup via Fastly or somethng else.


(Ivan Rapekas) #18

Our site is CUBA.Platform
Sure, we cannot provide admin access. But I promise that force https has been enabled. In browser I press ctrl+u to ensure that all users urls come with ssl.


(Felix Freiberger) #19

@Ivan_Rapekas, what is the URL to your site?
This might be some problem with your HTTPS setup.


(Ivan Rapekas) #20

@fefrei, https://www.cuba-platform.com/discuss
Server accepts requests via nginx https-proxy. Everything except mobile app (and some sub folder routing issues - known bugs) works fine.


Cannot reply here on Meta
(Felix Freiberger) #21

Hm, looks like HTTPS is innocent here. I’m running into the same issue on iOS (even when including the trailing slash), so this indeed looks like a subfolder issue.

On a side note, you should fix your HTTPS setup, you’re using weak Diffie-Hellman parameters. See https://weakdh.org/ for details and user SSL Labs to test your site again after you made the necessary changes. For reference, here is you current rating:

Most likely, making sure that Nginx is up to date and uses the following cipher list is enough:

ssl_ciphers 'ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-SHA384:ECDHE-RSA-AES256-SHA384:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA256';

(Ivan Rapekas) #24

@fefrei Thank you for detailed research! I passed the information to our site admins.

The topic problem resolved with 1.9.0 after update. Now Android application fully supports forums located in subfolder. Many thanks to team for the update!:slightly_smiling_face:


(Joffrey Jaffeux) #25