Any chance of supporting winmail.dat from old MS Exchange installations?


is there any chance of discourse email in supporting winmail.dat (ie the crap ms exchange sends for email attachments)?

What do you mean by “support” it?

Unpacking the attachments stored inside winmail.dat (which is how Outlook packs them up, all in 1 file, by default), instead of showing the winmail.dat file as an attachment, which nothing can open.

That doesn’t seem like a worthwhile investment of engineering effort to me? Why can’t Outlook open its own winmail.dat, if it’s the entity creating the file in the first place?

I agree with @codinghorror here, feels to me like outlook is trying to dictate some crazy standard here, how does gmail/proton mail/hotmail handle this ?

Fair enough. It was after all just a request.

Outlook (and Exchange) defaults to what they call “Richtext formatting” and when this is used they tend to send attachments as this file, which is fairly annoying and nothing else seems to be able to open it (even Outlook itself doesn’t respond to winmail.dat, it only decodes mail with that inside it). Feel free to close this.


Microsoft aren’t mandating or standardizing on winmail.dat. I’m sure that it was turned off by default in Outlook when I last installed it. The problem may be with:

  • older Outlook installs where the settings still need to be changed.
  • which has different settings than the Outlook application

There are two settings that can be set in Outlook | File | Options | Mail as shown in the following article:


Yep. the real issue is that incoming mail is usually from a badly configured customer we don’t control.

1 Like

Most people using Outlook will change their settings if they discover that the recipients of their messages aren’t able to read RTF text that hasn’t been converted to HTML.

Just remind them that the future is HTML. :rocket:


As I suspected, most Exchange installations are set to use the client settings. That can be turned off for all users.

Here are the steps to fix it - see

Login to your exchange server
Open Exchange Management Console
Go to Organization Configuration then Hub Transport
Select the Remote Domain tab
Go to the Default Domain and select Properties
Select the Message Format tab
Set Exchange rich-text format to Never use instead of Determined by individual user settings


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.