App.yml OVH SMTP config


#1

Hello,

Sorry for my sketchy english, I’ll try to do my best :pensive:

I have registered a domain name with OVH and created a special email adress for discourse : no-reply@myOVHdomain.fr
My Discourse forum is hosted on digital ocean .

The installation work great, but it never send mail to my developer email adresse,
I think i cant make the SMTP configuration work.

Did someone got the same probleme with OVH ? @pl3bs ?

i have try different combinason with the port 465 and 587 and the server name ssl.ovh.net , ns0.ovh.net and smtp.myOVHdomain.org , but none of them worked.

The port and the server name comes form those docuemtation:
http://guide.ovh.com/configurationemail
https://www.ovh.com/fr/g1474.mutualise_generalite_mail_mutualise_ovh

with smtp.myOVHdomain.org port 587 I got the exeption:
Job exception: hostname “smtp.projet-arthur.org” does not match the server certificate

with ns0.ovh.net port 587 I got the exeption:
Job exception: hostname “ns0.ovh.net” does not match the server certificate

with ssl.ovh.net port 587 i got the exeption :
Job exception: getaddrinfo: Name or service not known

with ssl.ovh.net port 465 i got the exeption :
Job exception: getaddrinfo: Name or service not known

with smtp.myOVHdomain.org port 465 and DISCOURSE_SMTP_ENABLE_START_TLS: false
i got the exeption : Job exception: Net::ReadTimeout


(Chethan Thimmappa) #2

Hi!

Can you try the default port number: 587 ? When did you purchase this domain name? May be it takes 24 hours for DNS Propagation?


#3

Hey che2on,

yes i have try the default one, actually all the ones that are on this page : Guides OVH : Aide et tutoriels sur le Web, Cloud et Telecom | OVH Docs

I have purchase this domain name last agust, but i created the no-reply email before the install. But login the no-reply email and checked if it worked before launching the install.


(omfg) #4

It’s interesting how the initial reaction (nothing personal) of people who fail to config their email is to ask this forum as if it’s possible for Discourse to control the sending of email without the server playing any role in it.

Maybe the docs should be improved and a comment added to the YML file, to just google it?

A simple google search for ova smtp email gave me the answer on the first page

http://guide.ovh.com/configurationemail


#5

Hi omfg,

I did a lot of research and i did the config that is on the page you send me but didnt work.

i have also try other port like 995,110,465,587 …

I also send a email to OVH support.

I wrote this post on the discourse forum to see if someone had the same issue with OVH.


(Chethan Thimmappa) #6

After changing the port did you ./launcher rebuild app ?


#7

yes i did, each time.


(Régis Hanol) #8

Are there any errors in your.discourse/logs that might help you diagnose this issue?


#9

I thnk the recommended approach is to use a 3rd party email service “battle tested”, for example Mandrill. There are plenty of configs here if you like to test it.

I’m hosting at OVH too, but I prefer to use Mandrill or Mailgun to push emails.


#10

.discourse/logs you mean /var/discourse/logs right ?
if its the case I dont see any logs file or repository (I did the installation with docker)


#11

thx for the advice Pablo,
I ll definitly do that if i dont fine any solution.
I there a reason why you prefer to use 3rd party email service ?
Personnaly i prefer to have my services “compact”


(Régis Hanol) #12

Nope, I mean htttp://your.discourse.com/logs :wink:


(omfg) #13

Okay. My comment wasn’t specific to you, although you hadn’t mentioned you tried the correct port as well.

More general stuff:

  • in troubleshooting I wouldn’t try the wrong ports, it doesn’t make much sense
  • I would list port(s) I did try, and paste a link to the source which advises to use those ports so that
  • we don’t have to google it
  • you show us what docs you followed

You didn’t do these steps and look how many people joined the topic and still no answer.

On the link I pasted above you have SMTP server info, whereas other hostname and ports are used for IMAP. Two services, two different host names.
Since you didn’t hadn’t explained which ports you tried in which combination with what setting, we can only keep guessing what doesn’t work. Most likely the instructions linked above work just fine. If they don’t, paste your config for each try.


#14

OK i have edit my post to make it more clear.
@zogstrip, i put my error on my post with the different configuraion


#15

I found the good config:

DISCOURSE_SMTP_ADDRESS: smtp.myOVHdomain.org
DISCOURSE_SMTP_PORT: 587
DISCOURSE_SMTP_ENABLE_START_TLS: false

(Régis Hanol) #16

(Jeff Atwood) #17