Arrow keys in Firefox

Arrow keys in the editor started acting a little strange in Firefox a few versions ago. The up and down arrows sometimes require an extra press to get past paragraphs.

To reproduce:

Create a new default Firefox profile. I was using Ubuntu 20.04.

firefox --new-instance --profile $(mktemp -d) &

Start a new forum post. Make a few paragraphs. Push the up and down arrow keys and watch for keypresses that don’t move the cursor.

Also, I’m not sure if this is a bug or if it was intended, but the tab index changed in the editor. Previously you could type a message, press tab and then you would be on the submit button, but now it takes 2 tab presses.

I can get used to the change, but I thought it might be a bug. If it was an accident, one tab is more convenient for keyboard-oriented users and will prevent them from having to relearn the muscle memory. I’m not sure if that one is a bug, so I’m just mentioning it in passing here.

1 Like

Sadly this looks like a Firefox bug :cry:

Up into a blank line in a TEXTAREA is not forcing a rerender of the cursor … sometimes.

Maybe … this ancient thing: 226301 - Cursor disappears sporadically

This feels like a new regression, worth hunting bugzilla.

Maybe post here: so they can help hunt down the right bug?


I’m not sure it’s a browser bug. The cursor doesn’t disappear, and I’ve been using Firefox since it was released without ever encountering this behavior. It only appeared within the past few Discourse updates of my main forum.

I just tried it again while writing this comment, and it seems like the cursor isn’t prevented from moving, but there’s often a 1-2 second delay when the cursor leaves a paragraph, like an event listener is doing some computation. It doesn’t happen every time. I’ve tried varying the speed of pressing the arrow keys, but I’m not sure if that has any effect on when it occurs.

Even if it’s a browser bug, doesn’t every browser have bugs that need to be accommodated? I’ve only tested it on one computer (multiple Firefox browser profiles), but it might be that everyone using Firefox is experiencing it on Discourse sites.

I’ll ask in the Mozilla forum in the meantime, since they might be able to identify what it is.

1 Like

Are you using the Windows version of Mozilla Firefox? I’ve had an issue like that before when I used to actively use a Windows computer in combination with Mozilla Firefox. The issue isn’t limited to Discourse communities. :cry:

1 Like

Yeah I am certainly open to accommodated for quirks and removing perf bottlenecks, but I have used Firefox for quite a while and this regression feel quite new. Let’s see what the folks at Mozilla have to say.

Repro on Linux with latest Firefox.


I’m using Ubuntu 20.04.

I just tried making a plain HTML page without any CSS or JS, and it’s very hard to reproduce there, but it does very rarely catch on the paragraph boundaries. (I had to try it many time before it happened.) I also went to Pastebin and was able to reproduce it there.

I think it’s a Firefox bug that is exacerbated by JavaScript or CSS. I probably haven’t noticed it elsewhere, because the textareas on the sites I visit were doing something different with JS/CSS.

I’ll file a bug report there and maybe they will get to it soon because it’s pretty big. Sorry for the trouble.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.