Authorized Extensions list with non-standard extension names

I run a forum supporting open source software called KiCad. After a recent upgrade, some of the file extensions that users often upload are no longer working. There is a thread about it here:

The thing I am keying in on is that it’s only the extensions that have underscores in them. I hadn’t seen any file extensions like that before KiCad, but it’s a large part of the file extensions that are part of the software. The board files have an extension of “.kicad_pcb” and the footprint files are “kicad_mod”.

I have all of the files listed in the “authorized extensions”, as well as the asterisk, in hopes of getting this working. I tried searching through the git repo as well, but couldn’t find any restrictions on the extension type (though it doesn’t mean that’s not the case).

1 Like

So only the ones with underscores are broken?

3 Likes

Yes, that’s correct.

3 Likes

I hadn’t thought to try it on another instance I have, just to make sure.

I just enabled the same extension (“kicad_mod”) and the upload works fine. However, it has the same behavior and when you click on the file link in the post, it goes to the default page that says “Oops! That page doesn’t exist or is private.”.

Is it possible this is more about the links that are created, rather than the actual upload? Are underscores allowed?

For instance, the link I just created was “/uploads/short-url/913bC7GjTf4cxyYtkr1Ej67ngER.kicad_mod”

For reference, I am using an S3 instance for storage Just double checked on the test instance and it’s using local storage.

2 Likes

Thanks for the report. I will check the issue next week.

5 Likes

This is another example by a forum user
https://forum.kicad.info/uploads/short-url/kkB1iEtT2JAEbNFZP4YclKPmgbC.kicad_pcb, who thought his upload had worked
An underscore again. The users are NOT trying to use Unicode characters.

1 Like

Now it is fixed by the below commit

4 Likes

Is there some way we’ll be notified when this is included in a beta build?

1 Like

Just tested this on our local install and it works well. Thank you for the update!

3 Likes