Auto close somehow getting turned on for admin


(Steven) #1

This problem only seems to affect admin users.
Only affects some posts, not all posts.

A admin user will create a new topic in a category. The topic will be posted to the forum successfully. There will be no warnings/notification on the initial topic that it will be auto closed. After about 5-10 mins, The topic will show that it will be auto close after 60 mins.

I am sure that I did not set the auto close flag for this topic.
I am sure that the category does not have the “auto close after x” flag set.
I am sure that none of my other admins set this flag either.

Installed version: v1.3.0.beta2 +31
URL: talk.hackspace.ca
Example: https://talk.hackspace.ca/t/is-it-caturday-yet/1711 (testing the mute function)


Admin/mods can post to "uncategorized" with "allow uncategorized topics" disabled
(Steven) #2

Here is another example of a post that automaticly was set up to auto close even though the admin did not set this flag
https://talk.hackspace.ca/t/how-did-they-do-this-hypnotic-kinetic-sculptures-by-jennifer-townley/1743/6?u=funvill

and another
https://talk.hackspace.ca/t/2015-classes-and-workshops/998/33?u=funvill

Only affects admins.


(Sam Saffron) #3

Maybe you have auto-close on the category itself? or some category it previously was in.


(Steven) #4

It doesn’t look like this is the problem.


(Sam Saffron) #5

Do any of your categories have Auto-close set?


(Steven) #6

Okay, I think I am getting closer to figuring this out…
But I have no idea how to fix it or how it happened.

There is this strange category that only admins can see. (it must have been made by another admin)

This category seems to have all the posts that are auto closing.
On creation of a new topic this “zzz !!! Don’t use this !!! old categorized” category is not select-able. Even for admins.

I tried clicking on this category so I could remove it or change its setting.
It goes to this page https://talk.hackspace.ca/c/zzz-dont-use-this-old-uncatagorized
Then auto redirects to a 404 page. https://talk.hackspace.ca/404

I am very sure that the “General” category (the default category) was selected on creation of these topics.

How do I delete this topic or change its settings?


(Steven) #7

None of the categories that I can click on and view the settings of are set to auto close.
I just checked them all again.

I do not know if this weird category (“zzz !!! Don’t use this !!! old categorized” ) has auto close enabled on it.


(Sam Saffron) #8

This may be the uncategorized category, can you try enabling uncategorized in site settings to see if it gives you access to it.

Be sure to evict all topics from it before disabling uncategorized again.


(Steven) #9

Thank you that worked.

I was able to edit this category after enabling uncategorized topics in the admin settings. The auto close setting was enabled on the settings for this category.

Thank you once again, this has been bugging me for a few weeks now.


(Sam Saffron) #10

cool, glad it is sorted


(Sam Saffron) #11