Aws getsockopt: connection refused

I followed this installation guide discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub. Everything is deployed on to a AWS EC2 instance running Ubuntu 18. The installation went fine, but when I open the public http://ec2-54-153-68-240.us-west-1.compute.amazonaws.com it throws “dial TCP 54.153.68.240:80: getsockopt: connection refused”. I tried to open the domain pointed to that instance, but no luck, same error. I am new to this any help is really appreciated. Thanks.

1 Like

Seems like Your EC2 comes with apache2 installed which I suspect is most likely installed because you installed LAMP on Ubuntu as your OS?

You’d probably need to reinstall/redeploy it with Ubuntu 18.04 (without the LAMP option) and then try reinstalling discourse.

Your installation must have failed in the first place since apache2 was running on that system (assuming that from ubuntu apache2 landing page).

3 Likes

Thanks for the help. I did a fresh install and it worked…

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.