Dial tcp IPaddress:80 getsockopt connection refused


I Installed Discourse in GCP VM instance Ubuntu Server using 30 minutes official Docs.
I am facing this issue dial tcp myIPaddress:80 getsockopt connection refused.
Kindly give me solution.

You need to setup your domain DNS to point to where discourse is installed

I pointed server external IP to A record in DNS.

then you need to look at your networking in GCP

Did you enable both HTTP Traffic and HTTPS Traffic while creating the VM? If not, you need to do it and also open firewall rules to allow the same.

1 Like

Thank you @IAmGav and @itsbhanusharma .
I created External Static IP address and Pointed with the VM instance. It’s working now.

1 Like

Glad it is working.

Enjoy using discourse :blush:

1 Like