Bitnami install on Google Cloud / Smooth except EMAIL


(John Schwitz) #1

Smooth install except I cannot get email to work. I cannot get sendgrid to work with Discourse. I believe the problem is on the server. Enclosed are logs. PROBLEM SOLVED SEE BELOW

GOOGLE CLOUD BLOCKS 587 I USED 2525.
Link to Google Docs:

PG::UndefinedTable: ERROR: relation "users" does not exist LINE 5: WHERE a.attrelid = '"users"'::regclass ^ : SELECT a.attname,
29 Nov 15
Scoped order and limit are ignored, it's forced to be batch order and batch size
29 Nov 15
Job exception: Network is unreachable - connect(2)
29 Nov 15
42		
Job exception: Network is unreachable - connect(2)
1 Jan 10:37 am
30		
Job exception: 534-5.7.9 Application-specific password required. Learn more at
Su 5:01 pm
PG::ConnectionBad (FATAL: the database system is shutting down ) /opt/bitnami/apps/discourse/htdocs/vendor/bundle/ruby/2.0.0/gems/activerecord-4.1.10/lib/active_record/connection_adapters/postgresql_
4:19 pm
5		
PG::ConnectionBad (FATAL: the database system is shutting down ) /opt/bitnami/apps/discourse/htdocs/vendor/bundle/ruby/2.0.0/gems/activerecord-4.1.10/lib/active_record/connection_adapters/postgresql_
4:23 pm
Job exception: FATAL: the database system is shutting down
4:25 pm
7		
PG::ConnectionBad (FATAL: the database system is shutting down ) /opt/bitnami/apps/discourse/htdocs/vendor/bundle/ruby/2.0.0/gems/activerecord-4.1.10/lib/active_record/connection_adapters/postgresql_
4:28 pm
19		
Job exception: execution expired
4:51 pm
3		
Discourse::InvalidParameters (email) /opt/bitnami/apps/discourse/htdocs/app/controllers/users_controller.rb:436:in `change_email'
4:56 pm

(Jeff Atwood) #2

Unfortunately, we can’t support the Bitnami install, sorry. We only support standard installs here due to time constraints.