Mail sending problem


I’ve installed Discourse from Google Cloud Marketplace (It’s not Bitnami).

First time I’ve start using Bitnami, but mail server do not worked, I’ve started using another template from GCP Marketplace. But there is same problem.

I’ve configurated SMTP with SendGrid.

When I’ve testing mail sending from admin panel, it works.
But when customer trying to register or recover password, mail service do not works.

Screenshot 1 (Test mail sending):
Screenshot 2 (Test mail receiving):

But another mails do not works.

How can I resolve this issue?

I can’t post GCP Marketplace link (I have not access for 3 link in same post).

Thank you

Are there any solution?

You will have to Check the SendGrid logs.

The test email worked so discourse did send it. what happens after that is not supported here.

I’ve already checked logs but in Sendgrid there is not nothing.
Sendgrid does not receive any message to send (except test mail).

I haven’t found a solution for more than 1 week.