Blank Page after Upgrading due to old Tagging Plugin


(Anand) #1

I tried upgrading to newer version from admin panel. After completion of the process the site is showing only blank page.

I tried upgrading through shh and it shows this message

So I ran the command again, its complete but still the site is not showing anything.


Totally blank page after upgrading
Discourse Docker Image version 1.3.3, released
(cpradio) #2

Follow the on screen instructions and run ./launcher rebuild app again


(Anand) #3

I did that, now I am seeing this. No instructions as such.


(Alan Tan) #4

Anything in ./launcher logs app?


(Anand) #5

something else went wrong.

now I am afraid…


(Anand) #6

@codinghorror any help sir.


(Dean Taylor) #7

This screenshot indicates you have ran out of space.

Read though this thread:

You might want to wait for feedback from one of the Discourse team for the best action to take.


(Anand) #8

Thanks! I am not very good at this and for the same reason I opted for installation services from discourse team itself. Waiting for Discourse team to response, with non-functional forum :frowning:


(Anand) #9

I cleaned the space

apt-get autoclean
apt-get autoremove
cd /var/discourse
./launcher cleanup

i ran upgrade command again

cd /var/discourse
git pull
./launcher rebuild app

it was complete and this was last screen

again blank page, nothing displaying the site.


(cpradio) #10

Do you have any plugins installed? Can you post what plugins are listed in your app.yml?


(Anand) #11

Yes, tagging and google adsense.

I tried removing adsense plugin and it worked! Thanks @cpradio for this suggestion.


(Mittineague) #13

The “No space left on device” is a pretty good clue to what the something is.

Did you try the commands the CLI listed as what you should do?

You don’t need to be afraid, you need to be extremely careful.

For those familiar only with GUIs, CLIs can be intimidating.
But they are what computers used to be way back before there was HTML

Just type very carefully and double check before you hit enter.

Usually a typo won’t result in a catastrophe, but that depends on what the typo is.

If you missed my saying it - be careful


(Alexandra) #14

While your advice in itself is good, I’m afraid it doesn’t really help @anandm09 to solve this problem, @Mittineague. Please bear in mind that this place can be a bit intimidating to newcomers …

I am new to this Docker stuff myself, so unfortunately I am unable to provide him with the steps to proceed with the upgrade but I assume he’d need to free up some space on his installation first, before backing up his postgres database as suggested in the screenshot.

Would it be safe to do

./launcher cleanup

at this stage?

Perhaps you could point him in the right direction with that?


(Alexandra) #15

After this thread got split from the main one, I guess my previous answer doesn’t really make sense any more …


(Anand) #16

Thanks for all the help but still there is some issue. When I upgraded after removing adsense plugin it worked on my device but I received many mails from our users that site is not working.

I check on multiple devices and realize that its working for few but not in others.

If you open IP address directly it works fine, but when website url is entered it does not show anything on devices with issue.

I have already tried deleting cache and temporary files from systems. It did not worked.

If I see error logs this is the common warning

What can be the possible cause for this and what should I do.

Note: I have already removed all plugins, only tag (offical) plugin is installed at the moment.


(Jeff Atwood) #17

Did you enable localization based on client browser language headers in your site settings?


(Anand) #18

Nope! Everything was working fine before upgrade. No changes made.


(Jeff Atwood) #19

Any JS customizations in Admin, Customize?


(Sam Saffron) #20

How can tags be installed? It is part of core now, remove it


(Anand) #21

I have removed

      - git clone https://github.com/discourse/discourse-tagging.git

Its working at my end, will check on different devices in some time and confirm the status.

If tagging is included in core, the plugin should be removed automatically while upgrading or there should be some notification remove it before updating.