Browser can't connect to server

Discourse pals, please help!

I’ve followed the 30-minute Discourse installation instructions, but when I enter in my address the browser (Safari & Chrome) both say they can’t connect to the server.

Details:
-ran the installation code in Terminal with root ssh
-Docker installed and working properly, hello world tests run
-have a 1GB droplet with Digital Ocean
-SMTP run and verified through Elastic Email
-at no time has the address worked (community.fatbesties.ca), nor the IP (159.203.41.177)
-I’ve run DNS tests and they come back without any errors

Thanks in advance for any input on this!

I doubt that either your installation didn’t complete successfully or there is some firewall rule blocking discourse. Can you confirm that your installation completed successfully?

1 Like

How would I go about confirming that?

First thing will be to check if the container is running.

You have 2 name servers and IP addresses showing for your domain. You are using the 2nd name server and the 2nd IP address. Have you tried using the first of each? Normally traffic is directed to the first, and in case of a power outage to the second. However, entering just your second and first level domains fatbeasties.ca does bring up your “This is a private site…” page. All other ways of trying fail.
Have you checked your ports?

Running a check on the domain returns:

Connect failure - perhaps firewall
Checked: 11.01.2020 08:44:34

1. IP-Addresses
Host	T	IP-Address	is auth.	∑ Queries	∑ Timeout
community.fatbesties.ca
	A
	159.203.41.177
Toronto/Ontario/Canada (CA) - DigitalOcean, LLC
No Hostname found

www.community.fatbesties.ca
	
	Name Error
	yes
	1
	0
NS [ns55.domaincontrol.com](https://mxtoolbox.com/SuperTool.aspx?action=dns%3afatbesties%2cca&run=toolpage#) [97.74.107.28](https://mxtoolbox.com/SuperTool.aspx?action=dns%3afatbesties%2cca&run=toolpage#)

GoDaddy.com, LLC (AS26496)
NS [ns56.domaincontrol.com](https://mxtoolbox.com/SuperTool.aspx?action=dns%3afatbesties%2cca&run=toolpage#) [173.201.75.28](https://mxtoolbox.com/SuperTool.aspx?action=dns%3afatbesties%2cca&run=toolpage#)

GoDaddy.com, LLC (AS26496)

But you have something that should be addressed here also:

Result
[![](upload://u2sUerRGFadM28m9VQeBOTcQrJa.png)](https://mxtoolbox.com/problem/dns/dns-soa-expire-value?page=prob_dns&action=dns:fatbesties.ca&showlogin=1&hidepitch=0&hidetoc=1) SOA Expire Value out of recommended range
ns55.domaincontrol.com reported Expire 604800 : Expire is recommended to be between 1209600 and 2419200. [![](upload://tslwDWFFeg1SU0uzUzv9fJ0VyXa.png) More Info ](https://mxtoolbox.com/problem/dns/dns-soa-expire-value?page=prob_dns&action=dns:fatbesties.ca&showlogin=1&hidepitch=0&hidetoc=1)