Can I disable the "topic similar to" pop-up entirely?


(Bryan Holst) #1

I recently set up Discourse and although the other users are enjoying it, I’m getting a lot of complaints about the “Your topic is similar to…” popup. I understand that you can just hit “x” to close, but can it be disabled entirely for now? Perhaps it will work better as there are more topics, etc, but for now it is completely irrelevant and a point of frustration for the other users. I’d like to disable it for now and try later when folks have settled in. Thanks in advance for your help!


(Felix Freiberger) #2

You could try setting minimum topics similar to a (very) high number.


How can turn off similar topic when i create a new topic?
(Bryan Holst) #3

I believe that setting is for the topics listed at the bottom of a thread. I am talking about the popup that comes up as you’re typing in the editor. :wink:


(Felix Freiberger) #4

Did you try it and it didn’t work? (Did you reload the site after changing the setting?)


(Bryan Holst) #5

Just did. No luck. Thank you though!


(Felix Freiberger) #6

Very strange. I just did, too, and it works for me…


(Bryan Holst) #7

how high of a number did you use? just curious, lol


(Felix Freiberger) #8

A lot. Maybe it was 50000?


#9

This works for me


(Bryan Holst) #10

That worked after all! Thanks guys!!


(Jeff Atwood) #11

Be careful with absurdly large numbers as they can cause integer overflows.


#12

No issues so far (it’s been ~a year) but I appreciate the heads up. :slight_smile:
What would you recommend in this instance?


(Jeff Atwood) #13

Something like 99,999,999 should suffice, really… more 9s isn’t adding more awesome :wink: