Can not choose category filter when create a new webhook

Im new to discourse, just created my instance for 5 days.
I tried to create a webhook, but when it come to the choose trigger category, nothing happened

webhooks work fine without the optional trigger filters, but I really need a filter in the future.
the groups filter works fine, haven’t test the tag filter, I need to learn how to create tags.
is this because of the language?



I would like to receive webhooks when a topic is created in a specific category on Discourse. However, I am currently unable to click the circle next to “Triggered Categories,” and when I click “Select…” below, all existing categories are listed, but selecting a category doesn’t result in anything being chosen. Any assistance would be greatly appreciated.

Thank you.


1 Like

Hello and welcome to you both. :slight_smile:

I’ve slipped your post over here @t_t to keep the reports grouped together. :+1:

I’ve just tried this on my test site and I’m also seeing the same issue. The category dropdown won’t allow me to select a value and this error appears in the console:


I am also experiencing the same issue. When can we expect the bug to be fixed?

Thanks for the reports! This issue will be resolved by FIX: Computed property override error for webhook.categories by davidtaylorhq · Pull Request #25418 · discourse/discourse · GitHub

1 Like

This topic was automatically closed after 3 days. New replies are no longer allowed.