Cannot access Discourse installation

I spun up a free tier VM with AWS to solely run Discourse. First setup went fine, I could view the success page, but I needed to redo it as I made a mistake with setting it up. Anyway, after making a new VPS, I followed the same install steps on digitalocean and after installation with no apparent issue, I am unable to connect to the Discourse. It’s running but 443 and 80 are closed despite me allowing all traffic going in and out of the server.

Don’t know what I am doing wrong here. Any ideas?

Thank you

Have you stablish the rules to open that ports in the proxy?

I think they are closed by default, just ssh 22 is opened to access cli.

Yeah, I did all traffic

So I tried to set this up on DigitalOcean and it seems like I am having the same issue. 80 and 443 seem blocked or Discourse is not running properly which it should be, no errors.

While setting up on DigitalOcean and following our guide closely (pick Ubuntu Server 18.04) ports 80 and 443 will never be blocked.

Did you setup the DNS correctly? What is the DNS and the IP of the DO droplet?

3 Likes

My DNS,

My IP 159.203.78.37.

Like mentioned above, I tried on AWS and it worked one time then not again afterward. Considering their tricky firewall setup, I tried a simpler way using DigitalOcean which yields the same result. Even followed the github instructions on fresh install

Edit;

Even using port checking tools, they are not open

How can you be sure discourse is up to be listening on those ports?

It’s more likely your build failed than anything in DO is filtering traffic.

I am using the $5 Droplet with 1GB of ram. Would that be an issue?

So I tried setting it up with OVH, same issue, 443 and 80 are closed on the IP. I am following these steps like I have numerous times for successful installations. Really confused and curious what I am doing wrong.

May be you have a proxy installed in your virtual Linux machine?

Are you sure you are using your public IP and it is your current IP adres?

In AWS each time you stop star an instance, you receive a new public IP address.
If you want a permanent one you have to create it using elastic IPs and pay for it.

In network interfaces you can check what is the public ip of your running interface.

1 Like

No proxy. I properly set up the elastic IPs. Between today and yesterday, tried installing on 3 fresh installations (DO, AWS, OVH) following the same steps I linked above.

I have a production instance running in lightsails and a test site using a free ec2 instance.
And we haven’t got this problem (well I forgot to open the amazon poxy a couple of times at first).

Sorry I could not help you.

1 Like

Have you not been using discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub? Those are the instructions that are supported here.

1 Like

Alright, going to try that on 18.04 fresh install

Followed it and still no luck. I have subdomains of the domain I am using on another VPS but that shouldn’t be an issue since the main was is forwarded to the VPS I am using. Any other things I could try?

Installed Apache on a refreshed VPS and that works. Going to do another attempt on installing Discourse

Reinstalled on a fresh OVH installation and got the same issue, Discourse installed (I think) but 443 and 80 are closed.

I tried netstat -tulpn and got this

What does docker ps say?

Are you using cloudflare for dns, with the orange cloud on?