Cannot get other categories than "General forum" to show up in the side bar for anonymous users

I have tried pretty much every setting, clearing caches, nothing seems to do. The categories “Blog comments”, “General forum” and “feedback” show up for authenticated users, but not for anonymous users. This could have the unfortunate effect of new people not quite finding their way to the essence of where I’m going to hook people into the community: blog comments that I host on Discourse (said blog is not live yet).

Screenshot for unauthenticated/anonymous user:

Screenshot when authenticated:
→ as a new user, I’m not allowed to show a second media item :slight_smile:

Note that on the latter, all three categories show.

The categories have the same settings. I’m explicitly setting the navbar setting to show them up.

Anonymous users can see the articles in the categories that are “hidden”, just the sidebar won’t show them.

hi Jerome, welcome to Meta :wave: :slight_smile:

have a look at the setting under admin-settings: default_navigation_menu_categories. there is also a corresponding setting for tags: default_navigation_menu_tags

also keep in mind that logged in users can override the navigation sidebar menu categories with their own category favorites by clicking the pencil icon beside the sidebar category header.


Thank you both for the welcome and your answer. Are the settings you mentionned meant to be found in here ?

I’m not seeing a match for either.

sorry my bad - i used “_” for space (coding habits :laughing: ) - the actual setting is default navigation menu categories without the underscore space.

*makes mental note to distinguish between settings and slugs by not using _ character


They should also work with the underscore in: :+1:

However, I think those settings were updated recently to change away from ‘sidebar’. Could you try default sidebar categories in case you’re on an older version @Jerome?


That worked indeed, thank you! I had been looking around for a couple of hours… I guess I’m only beginning to understand the breadth and depth of settings. I’m not able to tag this as solved, but solved it is indeed!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.