Cannot paste link in composer with Android Chrome



  1. Try to paste a link in composer.

It seems to only happening on mobile. I tried it on Android.

My forum is on e92f57255d but I tried it on Meta too and same issue.

I tested it with Android 10 Chrome 98.0.4758.87

Thanks :slightly_smiling_face:

Update: It seems to only the external links affected. If I copy a link in meta than I can paste it but if I go to a website and copy that link than I cannot paste it.


  • But OneBox is missing

Works with iPhone/Hub

And when using common linking in text (iPhone/Safari)

1 Like

Just updated to 98.0.4758.87. Now I have the same problem. I can copy and paste the link posted by @Jagster . But not something I copied from the address bar. It seems to work if I don’t copy from the address bar

2 Likes links like don’t work…
discourse - Wiktionary

… because of:

You can only see this note in preview on desktop - I think on mobile there is no preview?

Does it also fail on mobile for a link from like

1 Like

This looks like a new privacy feature of Chrome on Android to not insert copied links into clipboard.

  1. Open website

  2. Tap on address bar

  3. Copy link via tap on icon

  4. Go somewhere like Discourse composer and try to insert via “long-tap” → context-menu → "insert
    This fails.

  5. Have a look on your keyboard - there is the link and can be inserted:


  1. Copy link and make it appear in clipboard.

  2. Results:

  3. And now you can insert the link anywhere - also via “long-tap” → context-menu → “insert”.


Hmm. Maybe this is the bug we discussed on dev @zogstrip @andrei with Android and pasting URLs? So weird!


Yes, this is the same bug.

There is a bug report about it on the official bug-tracker - 1295617 - chromium - An open-source project to help move the web forward. - Monorail. Note that you can vote for it. To do it, login via Google and toggle this button with the star:

This happens only when using the copy button on the address bar:

the copy button

Everything works just fine when coping a link from the web page (even an external link) or when coping a link from the address bar “manually”:

  • tap on the edit button:
    the edit button
  • select URL in address bar
  • copy it using the context menu

I, personally, doubt that this is a security feature. That would be pretty confusing UX in my opinion. And I tried to find some announce of it, and found nothing. My guess is that this is a bug in Chrome, and the fact that the link appears in the clipboard after tapping the button with an eye is a side effect of pressing that button.


I’m pretty sure it’s all about preventing clipboard snooping.

Quite similar to the Android clipboard prompt feature:

iOS: TikTok and 32 other iOS apps still snoop your sensitive clipboard data | Ars Technica

Edit: @andrei so you were right, it’s not a security feature :clap:
The team at chromium pinpointed the error to this feature: [Omnibox] Clipboard can set and detect URL mime type


The Chromium team merged the fix for this bug. Note that the fix isn’t published yet.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.